aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 10:24:46 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:44 +0000
commitc46e6a05c6cbb14f740a04718bbfc3249a01765b (patch)
treee9ef4433b9f279793f628087c8352ef975092931
parent3eb37f13c4a7bd86efa6cb42e49dfa2df8aaee4d (diff)
downloadports-c46e6a05c6cbb14f740a04718bbfc3249a01765b.tar.gz
ports-c46e6a05c6cbb14f740a04718bbfc3249a01765b.zip
net/mediastreamer: Move to FFmpeg 4
Fails to build with FFmpeg 6 PR: 270314 Approved by: portmgr (blanket, build fix) Sponsored by: Blinkinblox
-rw-r--r--net/mediastreamer/Makefile4
-rw-r--r--net/mediastreamer/files/patch-CMakeLists.txt10
2 files changed, 13 insertions, 1 deletions
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index fd0c9636b10a..2d57e2201d46 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -54,7 +54,7 @@ VIDEOOPT_DESC= Video options
QTGL_DESC= Qt OpenGL rendering support
FFMPEG_IMPLIES= VIDEO
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+FFMPEG_LIB_DEPENDS= libavcodec.so.58:multimedia/ffmpeg4
FFMPEG_CMAKE_BOOL= ENABLE_FFMPEG
G726_LIB_DEPENDS= libspandsp.so:comms/spandsp
G726_CMAKE_BOOL= ENABLE_G726
@@ -98,6 +98,8 @@ XVIDEO_LDFLAGS= -L${LOCALBASE}/lib -lX11
post-patch:
@${REINPLACE_CMD} 's,gsm/gsm\.h,gsm.h,' \
${WRKSRC}/cmake/FindGSM.cmake ${WRKSRC}/src/audiofilters/gsm.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
.if ${CHOSEN_COMPILER_TYPE} == gcc
@${REINPLACE_CMD} '/-Wno-format-truncation/d' ${WRKSRC}/CMakeLists.txt
.endif
diff --git a/net/mediastreamer/files/patch-CMakeLists.txt b/net/mediastreamer/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..af4f8c14d640
--- /dev/null
+++ b/net/mediastreamer/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2023-04-25 11:15:51 UTC
++++ CMakeLists.txt
+@@ -260,6 +260,7 @@ if(ENABLE_VIDEO)
+ add_definitions(-DVIDEO_ENABLED)
+ endif()
+ if(ENABLE_FFMPEG)
++ set(CMAKE_PREFIX_PATH "%%LOCALBASE%%/ffmpeg4;%%LOCALBASE%%/ffmpeg4/libexec")
+ find_package(FFMpeg REQUIRED)
+ else()
+ add_definitions(-DNO_FFMPEG)