aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-23 12:42:59 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-25 14:04:50 +0000
commitc4ba600cdabc8ea3436cdd07253a11f70837112a (patch)
tree4597a9f7e8df695caade8483ba2654f611bc8358
parentf29a6093c6e7215947630b12ae1885908e39fec2 (diff)
downloadports-c4ba600cdabc8ea3436cdd07253a11f70837112a.tar.gz
ports-c4ba600cdabc8ea3436cdd07253a11f70837112a.zip
devel/aws-crt-cpp: Add new port
C++ wrapper around the aws-c-* libraries. Provides Cross-Platform Transport Protocols and SSL/TLS implementations for C++.
-rw-r--r--devel/aws-crt-cpp/Makefile36
-rw-r--r--devel/aws-crt-cpp/distinfo3
-rw-r--r--devel/aws-crt-cpp/pkg-descr4
-rw-r--r--devel/aws-crt-cpp/pkg-plist35
4 files changed, 78 insertions, 0 deletions
diff --git a/devel/aws-crt-cpp/Makefile b/devel/aws-crt-cpp/Makefile
new file mode 100644
index 000000000000..4b7c8cda739b
--- /dev/null
+++ b/devel/aws-crt-cpp/Makefile
@@ -0,0 +1,36 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+
+PORTNAME= aws-crt-cpp
+PORTVERSION= 0.17.2
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= C++ wrapper around the aws-c libraries
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libaws-c-mqtt.so:devel/aws-c-mqtt \
+ libaws-c-event-stream.so:devel/aws-c-event-stream \
+ libaws-c-s3.so:devel/aws-c-s3 \
+ libaws-checksums.so:devel/aws-checksums \
+ libaws-c-auth.so:security/aws-c-auth \
+ libaws-c-http.so:devel/aws-c-http \
+ libaws-c-io.so:devel/aws-c-io \
+ libs2n.so:security/s2n \
+ libaws-c-compression.so:devel/aws-c-compression \
+ libaws-c-cal.so:security/aws-c-cal \
+ libaws-c-sdkutils.so:devel/aws-c-sdkutils \
+ libaws-c-common.so:devel/aws-c-common
+
+USES= cmake compiler:c11 ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= awslabs
+
+CMAKE_ARGS+= -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_DEPS=OFF -DCMAKE_PREFIX_PATH=${LOCALBASE}
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/aws-crt-cpp/distinfo b/devel/aws-crt-cpp/distinfo
new file mode 100644
index 000000000000..aae51d8a8a5d
--- /dev/null
+++ b/devel/aws-crt-cpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634844290
+SHA256 (awslabs-aws-crt-cpp-v0.17.2_GH0.tar.gz) = 1fbdca51cc72349f4075119c5c272830578f48b7115b090b26500662027503d8
+SIZE (awslabs-aws-crt-cpp-v0.17.2_GH0.tar.gz) = 1066823
diff --git a/devel/aws-crt-cpp/pkg-descr b/devel/aws-crt-cpp/pkg-descr
new file mode 100644
index 000000000000..944f03431dce
--- /dev/null
+++ b/devel/aws-crt-cpp/pkg-descr
@@ -0,0 +1,4 @@
+C++ wrapper around the aws-c-* libraries.
+Provides Cross-Platform Transport Protocols and SSL/TLS implementations for C++.
+
+WWW: https://github.com/awslabs/aws-crt-cpp
diff --git a/devel/aws-crt-cpp/pkg-plist b/devel/aws-crt-cpp/pkg-plist
new file mode 100644
index 000000000000..a79b068d92ea
--- /dev/null
+++ b/devel/aws-crt-cpp/pkg-plist
@@ -0,0 +1,35 @@
+include/aws/crt/Api.h
+include/aws/crt/Config.h
+include/aws/crt/DateTime.h
+include/aws/crt/Exports.h
+include/aws/crt/ImdsClient.h
+include/aws/crt/JsonObject.h
+include/aws/crt/Optional.h
+include/aws/crt/StlAllocator.h
+include/aws/crt/StringUtils.h
+include/aws/crt/StringView.h
+include/aws/crt/Types.h
+include/aws/crt/UUID.h
+include/aws/crt/auth/Credentials.h
+include/aws/crt/auth/Signing.h
+include/aws/crt/auth/Sigv4Signing.h
+include/aws/crt/crypto/HMAC.h
+include/aws/crt/crypto/Hash.h
+include/aws/crt/http/HttpConnection.h
+include/aws/crt/http/HttpConnectionManager.h
+include/aws/crt/http/HttpProxyStrategy.h
+include/aws/crt/http/HttpRequestResponse.h
+include/aws/crt/io/Bootstrap.h
+include/aws/crt/io/ChannelHandler.h
+include/aws/crt/io/EventLoopGroup.h
+include/aws/crt/io/HostResolver.h
+include/aws/crt/io/SocketOptions.h
+include/aws/crt/io/Stream.h
+include/aws/crt/io/TlsOptions.h
+include/aws/crt/io/Uri.h
+include/aws/crt/mqtt/MqttClient.h
+include/aws/iot/MqttClient.h
+lib/aws-crt-cpp/cmake/aws-crt-cpp-config.cmake
+lib/aws-crt-cpp/cmake/shared/aws-crt-cpp-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/aws-crt-cpp/cmake/shared/aws-crt-cpp-targets.cmake
+lib/libaws-crt-cpp.so