aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 20:41:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 20:41:47 +0000
commitc4d00da330ffa3ea2745072c4b84dca9bb8c60fd (patch)
tree34853bcbac1d324401291a3175cd1510d957c9ad
parent2c07f6ee1fc94df364271d292e2caf02e945a207 (diff)
downloadports-c4d00da330ffa3ea2745072c4b84dca9bb8c60fd.tar.gz
ports-c4d00da330ffa3ea2745072c4b84dca9bb8c60fd.zip
devel/py-lxml: force regeneration of cython files
This fixes build with upcoming python 3.11 and potential future version compatibility problems. While here, add another WWW:.
-rw-r--r--devel/py-lxml/Makefile8
-rw-r--r--devel/py-lxml/pkg-descr1
2 files changed, 7 insertions, 2 deletions
diff --git a/devel/py-lxml/Makefile b/devel/py-lxml/Makefile
index deafb73ffae6..40be577cb179 100644
--- a/devel/py-lxml/Makefile
+++ b/devel/py-lxml/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/doc/licenses/BSD.txt
USES= compiler cpe gnome python:3.6+ uniquefiles:dirs
USE_GNOME= libxml2 libxslt
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent cython distutils
LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib
@@ -25,7 +25,11 @@ OPTIONS_DEFINE= DOCS
# needed for test to work
PYDISTUTILS_BUILD_TARGET= build_ext
-PYDISTUTILS_BUILDARGS= --inplace
+PYDISTUTILS_BUILDARGS= --inplace
+
+# force regeneration of cython files
+post-extract:
+ @${FIND} ${WRKSRC} -name "*.c" -delete
post-install:
@${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} \
diff --git a/devel/py-lxml/pkg-descr b/devel/py-lxml/pkg-descr
index 7022da9aeec2..fffd699a75b2 100644
--- a/devel/py-lxml/pkg-descr
+++ b/devel/py-lxml/pkg-descr
@@ -7,3 +7,4 @@ lxml is a Python binding for libxml2 and libxslt. Its aim:
* No manual memory management!
WWW: https://lxml.de/
+WWW: https://github.com/lxml/lxml