aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-21 19:16:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-21 19:16:58 +0000
commitc5001da196d78e21aae31258b54b7216add17a7f (patch)
treea43c5516c37e9d606005625fd152ff297d953576
parent7c6c0b205d69e0a848bb06d22ba411ec3464ee69 (diff)
downloadports-c5001da196d78e21aae31258b54b7216add17a7f.tar.gz
ports-c5001da196d78e21aae31258b54b7216add17a7f.zip
audio/kaldi: Unbreak on i386
The build looks for the __SSE2_MATH__ macro that clang doesn't define.
-rw-r--r--audio/kaldi/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/kaldi/Makefile b/audio/kaldi/Makefile
index 1de88fcfcb79..2397362e7254 100644
--- a/audio/kaldi/Makefile
+++ b/audio/kaldi/Makefile
@@ -26,7 +26,7 @@ CMAKE_OFF= KALDI_BUILD_TEST
CMAKE_ARGS= -DPython_EXECUTABLE=${PYTHON_CMD} \
-DKALDI_VERSION=${PORTVERSION}
-CXXFLAGS_i386= -msse -mfpmath=sse # SSE is off by default on i386 and compilation fails: /usr/local/include/fst/float-weight.h:99:2: error: "Please compile with -msse -mfpmath=sse, or equivalent."
+CXXFLAGS_i386= -msse -mfpmath=sse -D__SSE2_MATH__ # __SSE2_MATH__ is a gcc-specific macro that the code looks for: https://gcc.gnu.org/legacy-ml/gcc-patches/2002-08/msg01345.html
post-extract:
@${FIND} ${WRKSRC} -name "*.orig" -delete