aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-02 14:58:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-02 18:44:26 +0000
commitc65c786b33a8c78e479cddaf6118e5c97a232bce (patch)
tree079fbae768131a5568d8dee6f2a2eb6b6414b0f5
parentba9b7f9ecc4ef191b7c836bb9cdbed4f056b1292 (diff)
downloadports-c65c786b33a8c78e479cddaf6118e5c97a232bce.tar.gz
ports-c65c786b33a8c78e479cddaf6118e5c97a232bce.zip
science/dirac: Broken on powerpc64, powerpc64le; Fix build on i386
Reported by: fallout
-rw-r--r--science/dirac/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/dirac/Makefile b/science/dirac/Makefile
index 3bc508113a4d..ba9e9416ebf9 100644
--- a/science/dirac/Makefile
+++ b/science/dirac/Makefile
@@ -13,8 +13,9 @@ WWW= http://diracprogram.org/doku.php
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_armv7= compilation fails: Error: Old-style type declaration REAL*16 not supported at (1)
-BROKEN_i386= error: Type mismatch in argument 'dsetid' at (1); passed INTEGER(8) to INTEGER(4), see https://gitlab.com/dirac/dirac/-/issues/36
+BROKEN_armv7= compilation fails: Error: Old-style type declaration REAL*16 not supported at (1)
+BROKEN_powerpc64= compilation fails: Error: Old-style type declaration REAL*16 not supported at (1)
+BROKEN_powerpc64le= compilation fails: Error: Old-style type declaration REAL*16 not supported at (1)
BUILD_DEPENDS= gmake:devel/gmake
LIB_DEPENDS= libblas.so:math/blas \
@@ -36,7 +37,7 @@ CMAKE_ARGS= -DMKL_FLAG=off
CFLAGS+= -DSYS_LINUX # see https://gitlab.com/dirac/dirac/-/issues/32
CXXFLAGS+= -DSYS_LINUX
-FFLAGS+= -DSYS_LINUX
+FFLAGS+= -DSYS_LINUX -fallow-argument-mismatch # -fallow-argument-mismatch to fix build on i386, see https://gitlab.com/dirac/dirac/-/issues/36
LDFLAGS+= -llapack -lblas
BINARY_ALIAS= make=${GMAKE} \