aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-01-05 10:41:36 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-01-05 10:42:41 +0000
commitc6726595919b70432f4676af378bbc4a4678bbaa (patch)
treeb086242c31c93ea26909fff46be4b87869e1f6fe
parent88a02ce67f7ca90faf039f7988cc8ba8b8f8af67 (diff)
downloadports-c6726595919b70432f4676af378bbc4a4678bbaa.tar.gz
ports-c6726595919b70432f4676af378bbc4a4678bbaa.zip
lang/ghc810: Switch to LLVM 11.
While the officially supported LLVM version for GHC 8.10 is 10, it does build with 11. Switch to make ot possible to remove llvm10 port.
-rw-r--r--lang/ghc810/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ghc810/Makefile b/lang/ghc810/Makefile
index 76e8b65cea02..2f1d8244f292 100644
--- a/lang/ghc810/Makefile
+++ b/lang/ghc810/Makefile
@@ -10,7 +10,7 @@ OPTIONS_DEFINE= DYNAMIC PROFILE
SLAVE_BUILD_MK= BUILD_SPHINX_HTML=NO
GHC_VERSION= 8.10.7
-LLVM_VERSION= 10
+LLVM_VERSION= 11
BASE_PACKAGES= Cabal-3.2.1.0 array-0.5.4.0 base-4.14.3.0 binary-0.8.8.0 \
bytestring-0.10.12.0 containers-0.6.5.1 deepseq-1.4.4.0 \
directory-1.3.6.0 exceptions-0.10.4 filepath-1.4.2.1 \
@@ -21,7 +21,7 @@ BASE_PACKAGES= Cabal-3.2.1.0 array-0.5.4.0 base-4.14.3.0 binary-0.8.8.0 \
terminfo-0.4.1.4 text-1.2.4.1 time-1.9.3 \
transformers-0.5.6.2 unix-2.7.2.2 xhtml-3000.2.2.1
BOOT_GHC_VERSION= 8.10.7
-BOOT_LLVM_VERSION= 10
+BOOT_LLVM_VERSION= 11
EXTRA_PATCHES= ${MASTERDIR}/files/extra-utils_llvm-targets_gen-data-layout.sh