aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJamie Landeg-Jones <jamie@catflap.org>2023-06-07 18:16:12 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2023-06-07 22:47:12 +0000
commitc69de36d0e8d18710b99af0b08a36a52055d37b9 (patch)
treea9811dabc8f58615e02c859fa56f8d06dc57a41e
parente41a7b0b24739804855d74a178c1d4d78449be7a (diff)
downloadports-c69de36d0e8d18710b99af0b08a36a52055d37b9.tar.gz
ports-c69de36d0e8d18710b99af0b08a36a52055d37b9.zip
security/py-certbot-dns-standalone: New port
Standalone DNS Authenticator plugin for Certbot This is a plugin that uses an integrated DNS server to respond to the _acme-challenge records, so the domain's records do not have to be modified. PR: 271889
-rw-r--r--security/Makefile1
-rw-r--r--security/py-certbot-dns-standalone/Makefile24
-rw-r--r--security/py-certbot-dns-standalone/distinfo3
-rw-r--r--security/py-certbot-dns-standalone/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 815ce6240119..f6bdf2d04568 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -876,6 +876,7 @@
SUBDIR += py-certbot-dns-rfc2136
SUBDIR += py-certbot-dns-route53
SUBDIR += py-certbot-dns-sakuracloud
+ SUBDIR += py-certbot-dns-standalone
SUBDIR += py-certbot-nginx
SUBDIR += py-certifi
SUBDIR += py-certstream
diff --git a/security/py-certbot-dns-standalone/Makefile b/security/py-certbot-dns-standalone/Makefile
new file mode 100644
index 000000000000..78f03c46c212
--- /dev/null
+++ b/security/py-certbot-dns-standalone/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= certbot-dns-standalone
+PORTVERSION= 1.1
+CATEGORIES= security python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jamie@catflap.org
+COMMENT= Standalone DNS Authenticator plugin for Certbot
+WWW= https://github.com/siilike/certbot-dns-standalone
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnslib>=0.9.0:dns/py-dnslib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>5.0.0:devel/py-mock@${PY_FLAVOR} \
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-standalone/distinfo b/security/py-certbot-dns-standalone/distinfo
new file mode 100644
index 000000000000..f900b597960e
--- /dev/null
+++ b/security/py-certbot-dns-standalone/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684977504
+SHA256 (certbot-dns-standalone-1.1.tar.gz) = fc0b02e5a4f818adac56efbba6903211d3ef4a4d157f1500489e5621a92c30a1
+SIZE (certbot-dns-standalone-1.1.tar.gz) = 12809
diff --git a/security/py-certbot-dns-standalone/pkg-descr b/security/py-certbot-dns-standalone/pkg-descr
new file mode 100644
index 000000000000..129d95b7c07a
--- /dev/null
+++ b/security/py-certbot-dns-standalone/pkg-descr
@@ -0,0 +1,4 @@
+Standalone DNS Authenticator plugin for Certbot (security/py-certbot).
+
+This is a plugin that uses an integrated DNS server to respond to the
+_acme-challenge records, so the domain's records do not have to be modified.