aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:12:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:06 +0000
commitc6b110ee4031a389f9643a7fc13609de51587766 (patch)
treedae02c420500e6149a63a3a0992e47e24a9dc0b1
parentb0a0cacc08d7ba9aad4fa2f176758c1bb332a1bf (diff)
downloadports-c6b110ee4031a389f9643a7fc13609de51587766.tar.gz
ports-c6b110ee4031a389f9643a7fc13609de51587766.zip
devel/py-weasel: Add py-weasel 0.3.4
Weasel lets you manage and share end-to-end workflows for different use cases and domains, and orchestrate training, packaging and serving your custom pipelines. You can start off by cloning a pre-defined project template, adjust it to fit your needs, load in your data, train a pipeline, export it as a Python package, upload your outputs to a remote storage and share your results with your team. Weasel can be used via the weasel command and we provide templates in our projects repo.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-weasel/Makefile31
-rw-r--r--devel/py-weasel/distinfo3
-rw-r--r--devel/py-weasel/files/patch-setup.cfg11
-rw-r--r--devel/py-weasel/pkg-descr7
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7a51b415a038..5f42fcc3ded7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5849,6 +5849,7 @@
SUBDIR += py-watchgod
SUBDIR += py-watermark
SUBDIR += py-wcwidth
+ SUBDIR += py-weasel
SUBDIR += py-weblib
SUBDIR += py-websockets
SUBDIR += py-websockify
diff --git a/devel/py-weasel/Makefile b/devel/py-weasel/Makefile
new file mode 100644
index 000000000000..c11758b722d4
--- /dev/null
+++ b/devel/py-weasel/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= weasel
+PORTVERSION= 0.3.4
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Small and easy workflow system
+WWW= https://github.com/explosion/weasel
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cloudpathlib>=0.7.0:devel/py-cloudpathlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}confection>=0.0.4<0.2.0:devel/py-confection@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydantic2>=1.7.4<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.13.0<3.0.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}smart-open>=5.2.1<7.0.0:net/py-smart-open@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}srsly>=2.4.3<3.0.0:devel/py-srsly@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typer>=0.3.0<0.10.0:devel/py-typer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wasabi>=0.9.1<1.2.0:textproc/py-wasabi@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-weasel/distinfo b/devel/py-weasel/distinfo
new file mode 100644
index 000000000000..9cbc5cfff3f7
--- /dev/null
+++ b/devel/py-weasel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448830
+SHA256 (weasel-0.3.4.tar.gz) = eb16f92dc9f1a3ffa89c165e3a9acd28018ebb656e0da4da02c0d7d8ae3f6178
+SIZE (weasel-0.3.4.tar.gz) = 38252
diff --git a/devel/py-weasel/files/patch-setup.cfg b/devel/py-weasel/files/patch-setup.cfg
new file mode 100644
index 000000000000..ff29acb5ebed
--- /dev/null
+++ b/devel/py-weasel/files/patch-setup.cfg
@@ -0,0 +1,11 @@
+--- setup.cfg.orig 2023-11-06 16:07:56 UTC
++++ setup.cfg
+@@ -37,7 +37,7 @@ install_requires =
+ wasabi>=0.9.1,<1.2.0
+ srsly>=2.4.3,<3.0.0
+ typer>=0.3.0,<0.10.0
+- cloudpathlib>=0.7.0,<0.17.0
++ cloudpathlib>=0.7.0
+ smart-open>=5.2.1,<7.0.0
+ requests>=2.13.0,<3.0.0
+ pydantic>=1.7.4,!=1.8,!=1.8.1,<3.0.0
diff --git a/devel/py-weasel/pkg-descr b/devel/py-weasel/pkg-descr
new file mode 100644
index 000000000000..219b6a6e5d0b
--- /dev/null
+++ b/devel/py-weasel/pkg-descr
@@ -0,0 +1,7 @@
+Weasel lets you manage and share end-to-end workflows for different use cases
+and domains, and orchestrate training, packaging and serving your custom
+pipelines. You can start off by cloning a pre-defined project template, adjust
+it to fit your needs, load in your data, train a pipeline, export it as a Python
+package, upload your outputs to a remote storage and share your results with
+your team. Weasel can be used via the weasel command and we provide templates in
+our projects repo.