aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-10-14 16:46:40 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-10-14 18:04:51 +0000
commitc6e42b9cb8733e947f25d40e206313c287ba84e1 (patch)
tree708cba0bb275d951fb78af529bdc1274a99c096c
parent5cf774568b275b7cdbe9e8eb55d4428043fa99fe (diff)
downloadports-c6e42b9cb8733e947f25d40e206313c287ba84e1.tar.gz
ports-c6e42b9cb8733e947f25d40e206313c287ba84e1.zip
games/SpaceCadetPinball: Decompilation of 3D Pinball for Windows
-rw-r--r--games/Makefile1
-rw-r--r--games/SpaceCadetPinball/Makefile22
-rw-r--r--games/SpaceCadetPinball/distinfo3
-rw-r--r--games/SpaceCadetPinball/files/patch-CMakeLists.txt30
-rw-r--r--games/SpaceCadetPinball/pkg-descr3
-rw-r--r--games/SpaceCadetPinball/pkg-message13
6 files changed, 72 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index cae037efb8fc..6f2db140e767 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -19,6 +19,7 @@
SUBDIR += OpenLara
SUBDIR += OpenTomb
SUBDIR += SRB2
+ SUBDIR += SpaceCadetPinball
SUBDIR += abbayedesmorts
SUBDIR += abe
SUBDIR += abstreet
diff --git a/games/SpaceCadetPinball/Makefile b/games/SpaceCadetPinball/Makefile
new file mode 100644
index 000000000000..2ca3b0dfefd8
--- /dev/null
+++ b/games/SpaceCadetPinball/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= SpaceCadetPinball
+PORTVERSION= 1.1.1.20211010
+CATEGORIES= games
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Decompilation of 3D Pinball for Windows
+
+LICENSE= MIT
+
+USES= cmake sdl xorg
+
+USE_GITHUB= yes
+GH_ACCOUNT= k4zmu2a
+GH_PROJECT= SpaceCadetPinball
+GH_TAGNAME= 5947727f8031db306126c49b9e4b6043da13ea22
+
+USE_SDL= mixer2 sdl2
+USE_XORG= ice sm x11 xext
+
+PLIST_FILES= bin/SpaceCadetPinball
+
+.include <bsd.port.mk>
diff --git a/games/SpaceCadetPinball/distinfo b/games/SpaceCadetPinball/distinfo
new file mode 100644
index 000000000000..e9c67f74500d
--- /dev/null
+++ b/games/SpaceCadetPinball/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634173384
+SHA256 (k4zmu2a-SpaceCadetPinball-1.1.1.20211010-5947727f8031db306126c49b9e4b6043da13ea22_GH0.tar.gz) = 88722eed058635dd939d23094bafe9dd31e51a55180f77ee16b4670538a33f3f
+SIZE (k4zmu2a-SpaceCadetPinball-1.1.1.20211010-5947727f8031db306126c49b9e4b6043da13ea22_GH0.tar.gz) = 931976
diff --git a/games/SpaceCadetPinball/files/patch-CMakeLists.txt b/games/SpaceCadetPinball/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b5954264b6f8
--- /dev/null
+++ b/games/SpaceCadetPinball/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+--- CMakeLists.txt.orig 2021-10-10 14:13:43 UTC
++++ CMakeLists.txt
+@@ -24,8 +24,10 @@ set(SDL2_BUILDING_LIBRARY ON)
+
+ find_package(SDL2 REQUIRED)
+ FIND_PACKAGE(SDL2_mixer REQUIRED)
++find_package(X11 REQUIRED)
++link_libraries(${X11_LIBRARIES})
+
+-include_directories(${SDL2_INCLUDE_DIR} ${SDL2_MIXER_INCLUDE_DIR})
++include_directories(${SDL2_INCLUDE_DIR} ${SDL2_MIXER_INCLUDE_DIR} ${X11_INCLUDE_DIR})
+ get_property(dirs DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} PROPERTY INCLUDE_DIRECTORIES)
+ foreach(dir ${dirs})
+ message(STATUS "Include dir='${dir}'")
+@@ -197,6 +199,8 @@ target_precompile_headers(SpaceCadetPinball
+ )
+
+ target_link_libraries(SpaceCadetPinball ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARY})
++
++install(TARGETS SpaceCadetPinball DESTINATION bin)
+
+ # On Windows, copy DLL to output
+ if(WIN32)
+@@ -213,4 +217,4 @@ if(WIN32)
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different "${SDL2_DLL_PATH}/SDL2.dll" $<TARGET_FILE_DIR:SpaceCadetPinball>
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different "${SDL2_MIXER_DLL_PATH}/SDL2_mixer.dll" $<TARGET_FILE_DIR:SpaceCadetPinball>
+ )
+-endif()
+\ No newline at end of file
++endif()
diff --git a/games/SpaceCadetPinball/pkg-descr b/games/SpaceCadetPinball/pkg-descr
new file mode 100644
index 000000000000..7631a457c5f7
--- /dev/null
+++ b/games/SpaceCadetPinball/pkg-descr
@@ -0,0 +1,3 @@
+Decompilation of Space Cadet - 3D Pinball for Windows.
+
+WWW: https://github.com/k4zmu2a/SpaceCadetPinball
diff --git a/games/SpaceCadetPinball/pkg-message b/games/SpaceCadetPinball/pkg-message
new file mode 100644
index 000000000000..d8bf387cdc10
--- /dev/null
+++ b/games/SpaceCadetPinball/pkg-message
@@ -0,0 +1,13 @@
+[
+{ type: install
+ message: <<EOM
+Note: The Space Cadet Pinball game resources are not included with this
+port. In order to obtain them, you will need a copy of Microsoft Windows
+between Windows NT 4.0 or 98 and Windows XP, or Full Tilt! Pinball, and
+copy the game resources into a folder where you will execute the
+SpaceCadetPinball binary from the command line.
+
+The resources are not included as they are copyrighted.
+EOM
+}
+]