aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2021-05-07 16:08:05 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2021-05-08 13:39:41 +0000
commitc6ffec1fc8cfc146ad0eee524653d8a0dd3a487b (patch)
tree40a30a6d9792b5bbb1d19e8b0494eaee18354db8
parent246d773077d67683c6cecf91af3e702b6b647282 (diff)
downloadports-c6ffec1fc8cfc146ad0eee524653d8a0dd3a487b.tar.gz
ports-c6ffec1fc8cfc146ad0eee524653d8a0dd3a487b.zip
graphics/ufraw: Update ufraw configuration
* Add --enable-jasper option to enable JPEG2000 support * Remove old/deprecate elements such as PC_FALSE not used anymore * Fix some optional configuration parameters * Add post-patch actions to modify configure.ac if some options are disabled. For some reasons, even if the option is 'disabled' the configure auto activates the the option if the required lib is installed. * Add missing dependencies for GIMP option * lint with portfmt and portclippy PR: 255400 Reported by: rhurlin
-rw-r--r--graphics/ufraw/Makefile80
-rw-r--r--graphics/ufraw/pkg-plist1
2 files changed, 48 insertions, 33 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 9f9d7534a3af..c714e6f965f7 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ufraw
PORTVERSION= 0.22.20210424
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= rodrigo@FreeBSD.org
@@ -9,56 +10,69 @@ COMMENT= Read and manipulate raw images from various digital cameras
LICENSE= GPLv2
-LIB_DEPENDS= libtiff.so:graphics/tiff \
- libpng.so:graphics/png \
- liblcms2.so:graphics/lcms2 \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libjasper.so:graphics/jasper \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ liblcms2.so:graphics/lcms2 \
+ libpng.so:graphics/png \
+ libtiff.so:graphics/tiff
+
+USES= autoreconf compiler:c++11-lang desktop-file-utils gettext gmake \
+ gnome jpeg pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= sergiomb2
+GH_PROJECT= ufraw
+GH_TAGNAME= f34669b
+USE_GNOME+= cairo gdkpixbuf2 glib20 gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-extras
-USES= compiler:c++11-lang desktop-file-utils gettext gmake jpeg pkgconfig autoreconf gnome
+CONFIGURE_ARGS= --enable-extras \
+ --enable-jasper
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-OPTIONS_DEFINE= CONTRAST DST EXIV2 LENSFUN FITS GIMP GTK2 GNOME
-OPTIONS_DEFAULT=CONTRAST EXIV2 LENSFUN GTK2
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= CONTRAST DST EXIV2 FITS GIMP GNOME GTK2 LENSFUN
+OPTIONS_DEFAULT= CONTRAST EXIV2 GTK2 LENSFUN
+OPTIONS_SUB= yes
CONTRAST_DESC= Enable contrast setting option
DST_DESC= Use local time for timestamps
FITS_DESC= FITS output support
GIMP_DESC= Install GIMP plugin
-USE_GITHUB= yes
-GH_ACCOUNT= sergiomb2
-GH_PROJECT= ufraw
-GH_TAGNAME= f34669b
-
-USE_GNOME+=glib20 gtk20 cairo gdkpixbuf2
-
CONTRAST_CONFIGURE_ENABLE= contrast
-DST_CONFIGURE_ENABLE= dst-correction
-EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
-EXIV2_VARS_OFF= PC_FALSE+=exiv2
-LENSFUN_LIB_DEPENDS= liblensfun.so:graphics/lensfun
-LENSFUN_VARS_OFF= PC_FALSE+=lensfun
-FITS_LIB_DEPENDS= libcfitsio.so:astro/cfitsio
-FITS_VARS_OFF= PC_FALSE+=cfitsio
-GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
-GIMP_CONFIGURE_WITH= gimp
-GIMP_VARS_OFF= PC_FALSE+=gimp
-GIMP_IMPLIES= GTK2
-GTK2_LIB_DEPENDS= libgtkimageview.so:x11-toolkits/gtkimageview
-GTK2_CONFIGURE_WITH= gtk
-GNOME_USE= GNOME=gconf2
-GNOME_CONFIGURE_ENABLE= mime
-GNOME_VARS= CATEGORIES+=gnome GCONF_SCHEMAS=${PORTNAME}.schemas
+DST_CONFIGURE_ENABLE= dst-correction
+EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
+FITS_LIB_DEPENDS= libcfitsio.so:astro/cfitsio
+FITS_CONFIGURE_WITH= cfitsio
+GIMP_IMPLIES= GTK2
+GIMP_LIB_DEPENDS= libbabl-0.1.so:x11/babl \
+ libgegl-0.4.so:graphics/gegl \
+ libgimp-2.0.so:graphics/gimp-app \
+ libjson-glib-1.0.so:devel/json-glib
+GIMP_CONFIGURE_WITH= gimp
+GNOME_USE= GNOME=gconf2
+GNOME_CONFIGURE_ENABLE= mime
+GNOME_VARS= CATEGORIES+=gnome \
+ GCONF_SCHEMAS=${PORTNAME}.schemas
+GTK2_LIB_DEPENDS= libgtkimageview.so:x11-toolkits/gtkimageview
+GTK2_CONFIGURE_WITH= gtk
+LENSFUN_LIB_DEPENDS= liblensfun.so:graphics/lensfun
post-patch:
${GREP} -Ilrs 'default(none)' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's/default(none)//g'
+ @${REINPLACE_CMD} -e 's|$$(datadir)/gconf/schemas|${PREFIX}/etc/gconf/schemas|g' \
+ ${WRKSRC}/Makefile.am
+
+post-patch-EXIV2-off:
+ @${REINPLACE_CMD} -e 's|exiv2 >= 0.20|exiv2 < 0|g' \
+ ${WRKSRC}/configure.ac
+
+post-patch-LENSFUN-off:
+ @${REINPLACE_CMD} -e 's|lensfun >= 0.2.5|lensfun < 0|g' \
+ ${WRKSRC}/configure.ac
+
post-install:
${INSTALL_DATA} ${WRKSRC}/ufraw.desktop ${STAGEDIR}${DESKTOPDIR}
diff --git a/graphics/ufraw/pkg-plist b/graphics/ufraw/pkg-plist
index ec092150b1d4..78e54e7b3e22 100644
--- a/graphics/ufraw/pkg-plist
+++ b/graphics/ufraw/pkg-plist
@@ -4,6 +4,7 @@ bin/nikon-curve
bin/ufraw-batch
%%GIMP%%libexec/gimp/2.2/plug-ins/ufraw-gimp
man/man1/ufraw.1.gz
+%%GNOME%%share/appdata/ufraw.appdata.xml
share/applications/ufraw.desktop
share/locale/ca/LC_MESSAGES/ufraw.mo
share/locale/cs/LC_MESSAGES/ufraw.mo