aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2023-03-12 12:21:06 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2023-03-12 12:21:31 +0000
commitc703ad1ad9ff0ecef79ec5ba1f1297328cae53ae (patch)
tree09a70259ea8efac60c1213f5e141d5d26c62c4d9
parentab143bf311bce2495414e3241c679b80ada321f9 (diff)
downloadports-c703ad1ad9ff0ecef79ec5ba1f1297328cae53ae.tar.gz
ports-c703ad1ad9ff0ecef79ec5ba1f1297328cae53ae.zip
archivers/snappy: update to 1.1.10.
-rw-r--r--archivers/snappy/Makefile4
-rw-r--r--archivers/snappy/distinfo6
-rw-r--r--archivers/snappy/files/patch-CMakeLists.txt8
-rw-r--r--archivers/snappy/files/patch-snappy.cc11
4 files changed, 20 insertions, 9 deletions
diff --git a/archivers/snappy/Makefile b/archivers/snappy/Makefile
index efd5f5b516ed..ef8ebc381e43 100644
--- a/archivers/snappy/Makefile
+++ b/archivers/snappy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= snappy
-PORTVERSION= 1.1.9
-PORTREVISION= 1
+PORTVERSION= 1.1.10
+PORTREVISION= 0
CATEGORIES= archivers
MAINTAINER= vanilla@FreeBSD.org
diff --git a/archivers/snappy/distinfo b/archivers/snappy/distinfo
index a07c71d53303..ff2ca326920c 100644
--- a/archivers/snappy/distinfo
+++ b/archivers/snappy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620309917
-SHA256 (google-snappy-1.1.9_GH0.tar.gz) = 75c1fbb3d618dd3a0483bff0e26d0a92b495bbe5059c8b4f1c962b478b6e06e7
-SIZE (google-snappy-1.1.9_GH0.tar.gz) = 1102382
+TIMESTAMP = 1678607829
+SHA256 (google-snappy-1.1.10_GH0.tar.gz) = 49d831bffcc5f3d01482340fe5af59852ca2fe76c3e05df0e67203ebbe0f1d90
+SIZE (google-snappy-1.1.10_GH0.tar.gz) = 1105312
diff --git a/archivers/snappy/files/patch-CMakeLists.txt b/archivers/snappy/files/patch-CMakeLists.txt
index 306df294b015..68d48af31447 100644
--- a/archivers/snappy/files/patch-CMakeLists.txt
+++ b/archivers/snappy/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2021-05-04 22:53:34 UTC
+--- CMakeLists.txt.orig 2023-03-08 23:44:00 UTC
+++ CMakeLists.txt
@@ -78,8 +78,10 @@ else(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions")
@@ -13,7 +13,7 @@
endif(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
# BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to make
-@@ -213,8 +215,7 @@ configure_file(
+@@ -235,8 +237,7 @@ configure_file(
"snappy-stubs-public.h.in"
"${PROJECT_BINARY_DIR}/snappy-stubs-public.h")
@@ -23,7 +23,7 @@
PRIVATE
"snappy-internal.h"
"snappy-stubs-internal.h"
-@@ -235,20 +236,35 @@ target_sources(snappy
+@@ -257,20 +258,35 @@ target_sources(snappy
$<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/snappy-stubs-public.h>
$<INSTALL_INTERFACE:include/snappy-stubs-public.h>
)
@@ -63,7 +63,7 @@
if(SNAPPY_BUILD_TESTS OR SNAPPY_BUILD_BENCHMARKS)
add_library(snappy_test_support "")
target_sources(snappy_test_support
-@@ -359,7 +375,7 @@ endif(SNAPPY_FUZZING_BUILD)
+@@ -381,7 +397,7 @@ endif(SNAPPY_FUZZING_BUILD)
include(GNUInstallDirs)
if(SNAPPY_INSTALL)
diff --git a/archivers/snappy/files/patch-snappy.cc b/archivers/snappy/files/patch-snappy.cc
new file mode 100644
index 000000000000..f97971659540
--- /dev/null
+++ b/archivers/snappy/files/patch-snappy.cc
@@ -0,0 +1,11 @@
+--- snappy.cc.orig 2023-03-12 08:04:09 UTC
++++ snappy.cc
+@@ -1290,7 +1290,7 @@ std::pair<const uint8_t*, ptrdiff_t> DecompressBranchl
+ DeferMemCopy(&deferred_src, &deferred_length, from, len);
+ }
+ } while (ip < ip_limit_min_slop &&
+- (op + deferred_length) < op_limit_min_slop);
++ (op + deferred_length) < (size_t)op_limit_min_slop);
+ exit:
+ ip--;
+ assert(ip <= ip_limit);