aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-15 20:57:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-15 21:01:57 +0000
commitc7b824ba239a8517734437f1b95fbc0998554785 (patch)
tree84f3f4da6525e0b716449ff2f1062c3ead5cec1b
parent11522f7bdce2fce64d70088a2e5c0fcb00633f38 (diff)
downloadports-c7b824ba239a8517734437f1b95fbc0998554785.tar.gz
ports-c7b824ba239a8517734437f1b95fbc0998554785.zip
security/seal: Update 3.6.5 -> 3.7.1
PR: 259191 Approved by: lwhsu (maintainer)
-rw-r--r--security/seal/Makefile9
-rw-r--r--security/seal/distinfo6
-rw-r--r--security/seal/pkg-plist1
3 files changed, 10 insertions, 6 deletions
diff --git a/security/seal/Makefile b/security/seal/Makefile
index e1195c8a0893..d1578714c929 100644
--- a/security/seal/Makefile
+++ b/security/seal/Makefile
@@ -1,5 +1,5 @@
PORTNAME= seal
-DISTVERSION= 3.6.5
+DISTVERSION= 3.7.1
CATEGORIES= security
MAINTAINER= lwhsu@FreeBSD.org
@@ -8,7 +8,7 @@ COMMENT= Microsoft Simple Encrypted Arithmetic Library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++17-lang
+USES= cmake:testing compiler:c++17-lang
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
GH_PROJECT= SEAL
@@ -16,7 +16,12 @@ USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= SEAL_USE_MSGSL SEAL_USE_ZLIB SEAL_USE_ZSTD # project clones repositories instead of using exrernal packages, see https://github.com/microsoft/SEAL/issues/329
+CMAKE_TESTING_ON= SEAL_BUILD_TESTS
+CMAKE_TESTING_TARGET= gtest
PLIST_SUB+= VERSION=${DISTVERSION} VER=${DISTVERSION:R}
+post-test: # run tests
+ @cd ${BUILD_WRKSRC} && bin/sealtest
+
.include <bsd.port.mk>
diff --git a/security/seal/distinfo b/security/seal/distinfo
index 2a72efbe0473..a38d0201c885 100644
--- a/security/seal/distinfo
+++ b/security/seal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622625253
-SHA256 (Microsoft-SEAL-3.6.5_GH0.tar.gz) = 77bfcb4a8b785206c419cdf7aff8c200250691518eeddc958f874d1f567b2872
-SIZE (Microsoft-SEAL-3.6.5_GH0.tar.gz) = 591480
+TIMESTAMP = 1634323555
+SHA256 (Microsoft-SEAL-3.7.1_GH0.tar.gz) = 27446ea4fcea334faabc7439b1e312603ed700e3d26a45ec8408fd1d114374ec
+SIZE (Microsoft-SEAL-3.7.1_GH0.tar.gz) = 593478
diff --git a/security/seal/pkg-plist b/security/seal/pkg-plist
index 02f8152f1221..64e29603a93d 100644
--- a/security/seal/pkg-plist
+++ b/security/seal/pkg-plist
@@ -36,7 +36,6 @@ include/SEAL-%%VER%%/seal/util/gcc.h
include/SEAL-%%VER%%/seal/util/globals.h
include/SEAL-%%VER%%/seal/util/hash.h
include/SEAL-%%VER%%/seal/util/hestdparms.h
-include/SEAL-%%VER%%/seal/util/intel_seal_ext.h
include/SEAL-%%VER%%/seal/util/iterator.h
include/SEAL-%%VER%%/seal/util/locks.h
include/SEAL-%%VER%%/seal/util/mempool.h