aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:08 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:51 +0000
commitc80b0d38ef8483dd9b752d4e5dfae70e8dab4d1a (patch)
treefb64d1c358749a73c22e0f68dace12dd03a9f4b2
parenta411a5013de610a70ed1a61a842765790a6da611 (diff)
downloadports-c80b0d38ef8483dd9b752d4e5dfae70e8dab4d1a.tar.gz
ports-c80b0d38ef8483dd9b752d4e5dfae70e8dab4d1a.zip
devel/py-hatch-semver: Add py-hatch-semver 1.0.1
hatch-semver is a plugin for hatch to support semantic versioning. Hatch-semver relies on python-semver for all the versioning logic.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hatch-semver/Makefile24
-rw-r--r--devel/py-hatch-semver/distinfo3
-rw-r--r--devel/py-hatch-semver/files/patch-pyproject.toml10
-rw-r--r--devel/py-hatch-semver/pkg-descr2
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a294289d501c..00f20e6c239e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4692,6 +4692,7 @@
SUBDIR += py-hatch-jupyter-builder
SUBDIR += py-hatch-nodejs-version
SUBDIR += py-hatch-requirements-txt
+ SUBDIR += py-hatch-semver
SUBDIR += py-hatch-vcs
SUBDIR += py-hatchling
SUBDIR += py-heapdict
diff --git a/devel/py-hatch-semver/Makefile b/devel/py-hatch-semver/Makefile
new file mode 100644
index 000000000000..ecdd560ff27e
--- /dev/null
+++ b/devel/py-hatch-semver/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= hatch-semver
+PORTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= hatch_semver-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Hatch plugin for semver versioning scheme
+WWW= https://github.com/Nagidal/hatch-semver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.8.0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}semver>=2.13.0<2.14:devel/py-semver@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-hatch-semver/distinfo b/devel/py-hatch-semver/distinfo
new file mode 100644
index 000000000000..7d1b948209d4
--- /dev/null
+++ b/devel/py-hatch-semver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677770927
+SHA256 (hatch_semver-1.0.1.tar.gz) = 245b6168e1de53dfa43c55a0f8a96d1c204924a515b704df790fb6855bad43b8
+SIZE (hatch_semver-1.0.1.tar.gz) = 19813
diff --git a/devel/py-hatch-semver/files/patch-pyproject.toml b/devel/py-hatch-semver/files/patch-pyproject.toml
new file mode 100644
index 000000000000..17cf018de7d7
--- /dev/null
+++ b/devel/py-hatch-semver/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2020-02-02 00:00:00 UTC
++++ pyproject.toml
+@@ -1,7 +1,6 @@
+ [build-system]
+ requires = [
+ "hatchling>=1.8.0",
+- "hatch-semver",
+ ]
+ build-backend = "hatchling.build"
+
diff --git a/devel/py-hatch-semver/pkg-descr b/devel/py-hatch-semver/pkg-descr
new file mode 100644
index 000000000000..65455c918b65
--- /dev/null
+++ b/devel/py-hatch-semver/pkg-descr
@@ -0,0 +1,2 @@
+hatch-semver is a plugin for hatch to support semantic versioning. Hatch-semver
+relies on python-semver for all the versioning logic.