aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:48:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:22 +0000
commitc8da16568f528b796a35ad9550df7c5e62c66822 (patch)
treea91f51157a19043722298c7bb4ed773d7336e097
parent88c9d2919c17d7beba4845ab7cd2fd9fd6f8fa89 (diff)
downloadports-c8da16568f528b796a35ad9550df7c5e62c66822.tar.gz
ports-c8da16568f528b796a35ad9550df7c5e62c66822.zip
textproc/py-sphinx-design: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--textproc/py-sphinx-design/Makefile7
-rw-r--r--textproc/py-sphinx-design/files/setup.py38
2 files changed, 3 insertions, 42 deletions
diff --git a/textproc/py-sphinx-design/Makefile b/textproc/py-sphinx-design/Makefile
index 022167619a9e..324522952def 100644
--- a/textproc/py-sphinx-design/Makefile
+++ b/textproc/py-sphinx-design/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinx-design
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,14 +13,12 @@ WWW= https://github.com/executablebooks/sphinx-design
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=4,1<6,1:textproc/py-sphinx@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/textproc/py-sphinx-design/files/setup.py b/textproc/py-sphinx-design/files/setup.py
deleted file mode 100644
index baed625e996f..000000000000
--- a/textproc/py-sphinx-design/files/setup.py
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['sphinx_design', 'sphinx_design.compiled']
-
-package_data = \
-{'': ['*']}
-
-install_requires = \
-['sphinx>=4,<6']
-
-extras_require = \
-{'code_style': ['pre-commit~=2.12'],
- 'rtd': ['myst-parser~=0.18.0'],
- 'testing': ['myst-parser~=0.18.0',
- 'pytest~=7.1',
- 'pytest-cov',
- 'pytest-regressions'],
- 'theme_furo': ['furo>=2022.06.04,<2022.07'],
- 'theme_pydata': ['pydata-sphinx-theme~=0.9.0'],
- 'theme_rtd': ['sphinx-rtd-theme~=1.0'],
- 'theme_sbt': ['sphinx-book-theme~=0.3.0']}
-
-setup(name='sphinx_design',
- version='%%PORTVERSION%%',
- description='A sphinx extension for designing beautiful, view size responsive web components.',
- author=None,
- author_email='Chris Sewell <chrisj_sewell@hotmail.com>',
- url=None,
- packages=packages,
- package_data=package_data,
- install_requires=install_requires,
- extras_require=extras_require,
- python_requires='>=3.7',
- )