aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:44:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:43 +0000
commitcaa325dc5363185de26c10b77d19ceb36d911eda (patch)
tree070988c0c22577d339aa62a4ea8e561713026faa
parent7834257d38edf4e2650291f51a31587a7a492da5 (diff)
downloadports-caa325dc5363185de26c10b77d19ceb36d911eda.tar.gz
ports-caa325dc5363185de26c10b77d19ceb36d911eda.zip
devel/py-jaraco.logging: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-jaraco.logging/Makefile10
-rw-r--r--devel/py-jaraco.logging/files/setup.py3
2 files changed, 5 insertions, 8 deletions
diff --git a/devel/py-jaraco.logging/Makefile b/devel/py-jaraco.logging/Makefile
index b7e61012ee58..9b1e05d61532 100644
--- a/devel/py-jaraco.logging/Makefile
+++ b/devel/py-jaraco.logging/Makefile
@@ -1,5 +1,6 @@
PORTNAME= jaraco.logging
PORTVERSION= 3.1.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,9 @@ WWW= https://github.com/jaraco/jaraco.logging
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco>=0:devel/py-jaraco@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tempora>=0:devel/py-tempora@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0:devel/py-pytest-black@${PY_FLAVOR} \
@@ -20,15 +23,12 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0:devel/py-pytest-black@${PY_
${PYTHON_PKGNAMEPREFIX}pytest-mypy>=0:devel/py-pytest-mypy@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
POST_PLIST= trim-jaraco-namespace
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
post-install:
@${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__init__.py*
-@${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__pycache__/__init__.*
diff --git a/devel/py-jaraco.logging/files/setup.py b/devel/py-jaraco.logging/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-jaraco.logging/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()