aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2021-06-24 12:53:12 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2021-06-24 12:54:24 +0000
commitcaa9499c7c7ecd5f17c18ffa6ebbfc00ec83e141 (patch)
tree44ddc077177933813f63da37e0833a5f72af00ec
parentcbcc83c3c345e6c4db8c509edde024b71a15f75b (diff)
downloadports-caa9499c7c7ecd5f17c18ffa6ebbfc00ec83e141.tar.gz
ports-caa9499c7c7ecd5f17c18ffa6ebbfc00ec83e141.zip
www/unit-perl: fix failed build on -CURRENT after clang12 import.
-rw-r--r--www/unit-perl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/unit-perl/Makefile b/www/unit-perl/Makefile
index 725afb62fefb..526a7fed4bb8 100644
--- a/www/unit-perl/Makefile
+++ b/www/unit-perl/Makefile
@@ -16,6 +16,11 @@ USE_RC_SUBR?= # reset to empty
MASTERDIR= ${.CURDIR}/../unit
+# Fix build failure on clang12
+.if ${OSVERSION} >= 1400023
+CFLAGS+= -Wno-compound-token-split-by-macro
+.endif
+
post-configure:
cd ${CONFIGURE_WRKSRC} && \
${CONFIGURE_CMD} perl --module=${UNIT_MODNAME}