aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-10-06 07:51:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-10-06 07:55:26 +0000
commitcb0ed5261c3c5308001cedf8ca38154dbff979cb (patch)
tree77c63102ecb040c4673c31ff5dfaad54c73cba22
parent802ee791a8da6299dbcd0bbdbfc30678d62d7c38 (diff)
downloadports-cb0ed5261c3c5308001cedf8ca38154dbff979cb.tar.gz
ports-cb0ed5261c3c5308001cedf8ca38154dbff979cb.zip
shells/bash: fix compilation after libncurses split in base
bash actually only requires libtinfo, but up to recent change in 14.0-CURRENT, libtinfo and libncurses were bundled into one single libs, so linking only to libncurses was not a problem. By telling bash to link to libtinfo and not to libncurses, it works on both system where ncurses has been split and those without the split as there is a libtinfow.so symlink to libncursesw.so on those.
-rw-r--r--shells/bash/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 61e2e3b0bcbf..19c1275f55ab 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+= --without-bash-malloc \
--enable-disabled-builtins \
--with-libiconv-prefix=${ICONV_PREFIX}
-MAKE_ARGS+= TERMCAP_LIB=-lncursesw
+MAKE_ARGS+= TERMCAP_LIB=-ltinfow
.if empty(PKGNAMESUFFIX)
CONFLICTS+= bash-static-[0-9]*