aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Jensen <erik@tenku.dk>2023-05-20 10:27:39 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-05-20 10:28:57 +0000
commitcb1a96b93ae02e5e826e120de6750ed8426d9fe9 (patch)
treefdc462eb5c3d6671de46294aeb37db3f43850cba
parent4b03671d17d53ae4dca6fd5bf4f32eacc41ec669 (diff)
downloadports-cb1a96b93ae02e5e826e120de6750ed8426d9fe9.tar.gz
ports-cb1a96b93ae02e5e826e120de6750ed8426d9fe9.zip
devel/root: Upgrade to 6.28/04
-rw-r--r--devel/root/Makefile6
-rw-r--r--devel/root/distinfo6
-rw-r--r--devel/root/files/patch-main_CMakeLists.txt13
-rw-r--r--devel/root/pkg-plist6
4 files changed, 21 insertions, 10 deletions
diff --git a/devel/root/Makefile b/devel/root/Makefile
index 727c70844298..fb4cb954185a 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -1,6 +1,5 @@
PORTNAME= root
-DISTVERSION= 6.28.02
-PORTREVISION= 2
+DISTVERSION= 6.28.04
CATEGORIES= devel science math parallel python
MASTER_SITES= https://root.cern/download/
DISTFILES= ${PORTNAME}_v${DISTVERSION}.source${EXTRACT_SUFX}
@@ -29,6 +28,7 @@ LIB_DEPENDS= libAfterImage.so:graphics/libafterimage \
libpng.so:graphics/png \
libtbb.so:devel/onetbb \
libtiff.so:graphics/tiff \
+ libunwind.so:devel/libunwind \
libvdt.so:math/vdt \
libxkbcommon.so:x11/libxkbcommon \
libXrdCl.so:databases/xrootd \
@@ -36,7 +36,7 @@ LIB_DEPENDS= libAfterImage.so:graphics/libafterimage \
libzstd.so:archivers/zstd
USES= blaslapack:openblas cmake compiler:c++17-lang desktop-file-utils \
- gettext-runtime gl gnome iconv jpeg mysql:57 pgsql:13+ python:3.9+ \
+ gettext-runtime gl gnome iconv jpeg mysql pgsql:13+ python:3.9+ \
shebangfix sqlite ssl xorg
USE_GL= glew glu opengl
USE_GNOME= cairo gdkpixbuf2 glib20 librsvg2 libxml2
diff --git a/devel/root/distinfo b/devel/root/distinfo
index 468a17b797ce..820f7bf6ff69 100644
--- a/devel/root/distinfo
+++ b/devel/root/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679508411
-SHA256 (root_v6.28.02.source.tar.gz) = 6643c07710e68972b00227c68b20b1016fec16f3fba5f44a571fa1ce5bb42faa
-SIZE (root_v6.28.02.source.tar.gz) = 185323243
+TIMESTAMP = 1684486312
+SHA256 (root_v6.28.04.source.tar.gz) = 70f7f86a0cd5e3f2a0befdc59942dd50140d990ab264e8e56c7f17f6bfe9c965
+SIZE (root_v6.28.04.source.tar.gz) = 185345719
diff --git a/devel/root/files/patch-main_CMakeLists.txt b/devel/root/files/patch-main_CMakeLists.txt
index 4e4c055be24a..faf1e5be1972 100644
--- a/devel/root/files/patch-main_CMakeLists.txt
+++ b/devel/root/files/patch-main_CMakeLists.txt
@@ -1,4 +1,4 @@
---- main/CMakeLists.txt.orig 2023-02-13 15:21:06 UTC
+--- main/CMakeLists.txt.orig 2023-05-19 13:45:40 UTC
+++ main/CMakeLists.txt
@@ -75,8 +75,8 @@ if(IS_ABSOLUTE ${runtimedir})
else()
@@ -11,3 +11,14 @@
configure_file(python/cmdLineUtils.py ${localruntimedir}/cmdLineUtils.py @ONLY)
+@@ -117,8 +117,8 @@ set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CL
+ "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/rootcint;${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/genreflex")
+
+ if(CMAKE_HOST_UNIX)
+- install(CODE "execute_process(COMMAND ln -f rootcling rootcint WORKING_DIRECTORY \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})" COMPONENT applications)
+- install(CODE "execute_process(COMMAND ln -f rootcling genreflex WORKING_DIRECTORY \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})" COMPONENT applications)
++ install(CODE "execute_process(COMMAND ln -f rootcling rootcint WORKING_DIRECTORY \${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})" COMPONENT applications)
++ install(CODE "execute_process(COMMAND ln -f rootcling genreflex WORKING_DIRECTORY \${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})" COMPONENT applications)
+ else()
+ if(MSVC)
+ install(PROGRAMS ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/rootcling.exe DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT applications)
diff --git a/devel/root/pkg-plist b/devel/root/pkg-plist
index e172028008fb..37e0f114849c 100644
--- a/devel/root/pkg-plist
+++ b/devel/root/pkg-plist
@@ -1,4 +1,3 @@
-bin/genreflex
bin/hadd
bin/hist2workspace
bin/prepareHistFactory
@@ -9,7 +8,6 @@ bin/root
bin/root-config
bin/root.exe
bin/rootbrowse
-bin/rootcint
bin/rootcling
bin/rootcp
bin/rootdrawtree
@@ -1135,7 +1133,6 @@ include/root/RooMultiGenFunction.h
include/root/RooMultiVarGaussian.h
include/root/RooNDKeysPdf.h
include/root/RooNLLVar.h
-include/root/RooNaNPacker.h
include/root/RooNameReg.h
include/root/RooNonCPEigenDecay.h
include/root/RooNonCentralChiSquare.h
@@ -7121,3 +7118,6 @@ lib/root/libRooFitXRooFit.so.%%SHLIB_VER%%
%%DATADIR%%/ui5/distribution/resources/sap/ui/commons/themes/sap_fiori_3/img-RTL/arrow_up.png
%%ONLY_INSTALLED_ON_AARCH64%%lib/root/%%AARCH64_PCM_PREFIX%%GenVector_G__GenVector32%%AARCH64_PCM_SUFFIX%%.pcm
%%ONLY_INSTALLED_ON_AARCH64%%lib/root/%%AARCH64_PCM_PREFIX%%Smatrix_G__Smatrix32%%AARCH64_PCM_SUFFIX%%.pcm
+include/root/RooFit/Config.h
+include/root/RooFit/ModelConfig.h
+include/root/RooStats/HistFactory/Detail/HistFactoryImpl.h