aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-21 20:36:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-21 21:33:50 +0000
commitcbf6cb97f2ad8890c2bf612f84e2e71417d386fd (patch)
treef2ce042a4c268c84edc210d0cb81c7073f3f5cb8
parent274b20e4c81e57d232a19ad490684374227862c7 (diff)
downloadports-cbf6cb97f2ad8890c2bf612f84e2e71417d386fd.tar.gz
ports-cbf6cb97f2ad8890c2bf612f84e2e71417d386fd.zip
math/clingo: Update 5.4.1 -> 5.5.0
Reported by: portscout
-rw-r--r--math/clasp/Makefile2
-rw-r--r--math/clingo/Makefile11
-rw-r--r--math/clingo/distinfo10
-rw-r--r--math/clingo/pkg-plist4
4 files changed, 18 insertions, 9 deletions
diff --git a/math/clasp/Makefile b/math/clasp/Makefile
index 8cd62bc71138..f4c81c4e5775 100644
--- a/math/clasp/Makefile
+++ b/math/clasp/Makefile
@@ -22,6 +22,8 @@ GH_TUPLE= potassco:libpotassco:6e31cff:other/libpotassco
PLIST_FILES= bin/${PORTNAME}
+CONFLICTS_INSTALL= clingo # bin/clasp is contained in clingo
+
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/math/clingo/Makefile b/math/clingo/Makefile
index f0b0588e6e0b..c34236782af4 100644
--- a/math/clingo/Makefile
+++ b/math/clingo/Makefile
@@ -1,6 +1,6 @@
PORTNAME= clingo
DISTVERSIONPREFIX= v
-DISTVERSION= 5.4.1
+DISTVERSION= 5.5.0
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -14,7 +14,7 @@ BUILD_DEPENDS= re2c:devel/re2c
USES= cmake compiler:c++14-lang
USE_GITHUB= yes
GH_ACCOUNT= potassco
-GH_TUPLE= potassco:clasp:b089aa1509511ab403c0b9abd0d13eb9e873af44:potassco_clasp/clasp \
+GH_TUPLE= potassco:clasp:a8dfc0a:potassco_clasp/clasp \
potassco:libpotassco:2f9fb7ca2c202f1b47643aa414054f2f4f9c1821:potassco_libpotassco/clasp/libpotassco
USE_LDCONFIG= yes
@@ -22,4 +22,11 @@ USE_LDCONFIG= yes
CMAKE_OFF= CLINGO_BUILD_WITH_PYTHON # broken, see https://github.com/potassco/clingo/issues/178
CMAKE_OFF+= CLINGO_BUILD_WITH_LUA
+CONFLICTS_INSTALL= clasp # only installs bin/clasp that is included in clingo
+
+do-test:
+ ${ECHO} "Testing ${PORTNAME}: solving 15puzzle"
+ @cd ${WRKSRC}/examples/clingo/15puzzle && \
+ ${STAGEDIR}${PREFIX}/bin/clingo encoding.lp instance1.lp -c consecutive=0
+
.include <bsd.port.mk>
diff --git a/math/clingo/distinfo b/math/clingo/distinfo
index 4f288d238b7a..9cef14bc2b2c 100644
--- a/math/clingo/distinfo
+++ b/math/clingo/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1607489618
-SHA256 (potassco-clingo-v5.4.1_GH0.tar.gz) = ac6606388abfe2482167ce8fd4eb0737ef6abeeb35a9d3ac3016c6f715bfee02
-SIZE (potassco-clingo-v5.4.1_GH0.tar.gz) = 2822845
-SHA256 (potassco-clasp-b089aa1509511ab403c0b9abd0d13eb9e873af44_GH0.tar.gz) = ab2ac6601292619f94831065ee5c009f3168e14be52a65df7b9abdc20a1fc33f
-SIZE (potassco-clasp-b089aa1509511ab403c0b9abd0d13eb9e873af44_GH0.tar.gz) = 627136
+TIMESTAMP = 1619035809
+SHA256 (potassco-clingo-v5.5.0_GH0.tar.gz) = c9d7004a0caec61b636ad1c1960fbf339ef8fdee9719321fc1b6b210613a8499
+SIZE (potassco-clingo-v5.5.0_GH0.tar.gz) = 3027366
+SHA256 (potassco-clasp-a8dfc0a_GH0.tar.gz) = f96cf2baf9522e7a69a58cfe20f41aecf59b9509129e0ee4f6cb674ca89bd358
+SIZE (potassco-clasp-a8dfc0a_GH0.tar.gz) = 627911
SHA256 (potassco-libpotassco-2f9fb7ca2c202f1b47643aa414054f2f4f9c1821_GH0.tar.gz) = 41eb8b7d87ecea48392de4ada455cda179cbd62fd63496355dea87e1e44b599f
SIZE (potassco-libpotassco-2f9fb7ca2c202f1b47643aa414054f2f4f9c1821_GH0.tar.gz) = 210177
diff --git a/math/clingo/pkg-plist b/math/clingo/pkg-plist
index 6437ca208cb7..b3152fa2f1a3 100644
--- a/math/clingo/pkg-plist
+++ b/math/clingo/pkg-plist
@@ -10,5 +10,5 @@ lib/cmake/Clingo/ClingoConfigVersion.cmake
lib/cmake/Clingo/ClingoTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Clingo/ClingoTargets.cmake
lib/libclingo.so
-lib/libclingo.so.3
-lib/libclingo.so.3.0
+lib/libclingo.so.4
+lib/libclingo.so.4.0