aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-04-21 01:51:52 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-04-21 02:06:22 +0000
commitcc6cd777dae7001e3e3a8c5492a1cbbb7af5d346 (patch)
treed9542e7be44d0be76a1aaaac0e847cbaeda05363
parent70b25dede7bd21984edbc7d18829c1f85543353e (diff)
downloadports-cc6cd777dae7001e3e3a8c5492a1cbbb7af5d346.tar.gz
ports-cc6cd777dae7001e3e3a8c5492a1cbbb7af5d346.zip
security/pinentry-qt6: Fix configure on 13.2
Qt 6.x requires C++17 and the C++ standard is not set for the configure script nor for the build. The base compiler on FreeBSD 13.2 defaults to C++11, causing the configure script to fail as would the build if it made it past the configure stage. Reported by: pkg-fallout
-rw-r--r--security/pinentry/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 87217f55c00c..1c36db0fdd9a 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -125,6 +125,7 @@ CONFIGURE_ARGS+=--disable-pinentry-qt5
.if ${PINENTRY_GUI} == "qt6"
USES+= compiler:c++17-lang kde:6 qt:6
+USE_CXXSTD= c++17
USE_KDE= guiaddons windowsystem
USE_QT= base
PLIST_FILES= bin/pinentry-qt \