aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-09-03 10:48:26 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-09-03 12:52:05 +0000
commitcd27f4b3cc83bf30ab4ecbf157aa8a69880196ba (patch)
tree0c5e69dfee8965cd7142b797daec468a43f12b45
parent6f2d279b56972b476fbf0b7a27ede3dc3f630696 (diff)
downloadports-cd27f4b3cc83bf30ab4ecbf157aa8a69880196ba.tar.gz
ports-cd27f4b3cc83bf30ab4ecbf157aa8a69880196ba.zip
multimedia/kdenlive: fix build when multimedia/mlt6 is installed
The build of kdenlive could wrongly pick up the unprefixed headers of multimedia/mlt6 in ${LOCALBASE}/include due to that path being added the CFLAGS -- so mlt++/Foo would get you the mlt6 header: /usr/local/include/mlt++/MltGeometry.h:34:31: [...] This patch appends ${LOCALBASE}/include at the end, so the prefixed mlt7 headers should get picked up first. Reported by: VVD <vvd@unislabs.com>
-rw-r--r--multimedia/kdenlive/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index f8844d68ea92..4b2deb1beef0 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -29,7 +29,7 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
buildtools_build qmake_build \
quickcontrols_run script svg webkit widgets
USE_XORG= x11
-CFLAGS+= -I${LOCALBASE}/include # linux/input.h
+CFLAGS+= -isystem${LOCALBASE}/include # linux/input.h
CMAKE_ARGS= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFX}"
# Keep in sync with multimedia/mlt, possibly.