aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-03 01:22:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-03 02:07:50 +0000
commitcd63849278627cd842bc8cdb41f076f005974a06 (patch)
tree518f1a61356be5bfa6ce14b585a6b9e7fc40128e
parentb097c5c9672126f607bacdca82479ff1ba7250fa (diff)
downloadports-cd63849278627cd842bc8cdb41f076f005974a06.tar.gz
ports-cd63849278627cd842bc8cdb41f076f005974a06.zip
x11-wm/gamescope: bundle libliftoff, preparing for update
This reverts commit e4627682874a487b3c8bde7f8d70a4532a549bed. (cherry picked from commit 8947b5348e896ba308935f13823954443ca3655c)
-rw-r--r--x11-wm/gamescope/Makefile3
-rw-r--r--x11-wm/gamescope/distinfo4
-rw-r--r--x11-wm/gamescope/files/patch-private-libs27
3 files changed, 30 insertions, 4 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 2cfbe22b672f..990ddd821046 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -9,7 +9,6 @@ PATCHFILES+= 01ac6a8e2699.patch:-p1 # https://github.com/Plagman/gamescope/pull/
PATCHFILES+= 43f743fcfbd0.patch:-p1 # https://github.com/Plagman/gamescope/pull/119
PATCHFILES+= 9ebb1c16d3ad.patch:-p1 # https://github.com/Plagman/gamescope/pull/119
PATCHFILES+= d59836199ebe.patch:-p1 # https://github.com/Plagman/gamescope/issues/120
-PATCHFILES+= 7ad78c179417.patch:-p1 # libliftoff 0.1.0
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Micro-compositor from SteamOS
@@ -24,7 +23,6 @@ BUILD_DEPENDS= glslangValidator:graphics/glslang \
wlroots>=0.13.0<0.14.0:x11-toolkits/wlroots
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libdrm.so:graphics/libdrm \
- libliftoff.so:graphics/libliftoff \
libvulkan.so:graphics/vulkan-loader \
libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
@@ -35,6 +33,7 @@ USE_GITHUB= yes
USE_SDL= sdl2
USE_XORG= x11 xcomposite xdamage xext xfixes xrender xres xtst xxf86vm
GH_ACCOUNT= Plagman
+GH_TUPLE= emersion:libliftoff:b08bbaa:libliftoff/subprojects/libliftoff
CPPFLAGS+= -D_WITH_DPRINTF # XXX Remove after FreeBSD 11 EOL
PLIST_FILES= bin/${PORTNAME}
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index b7a757b0ecfb..43a46796152d 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -1,6 +1,8 @@
TIMESTAMP = 1625025715
SHA256 (Plagman-gamescope-3.8.4_GH0.tar.gz) = 761d0baa20b683cb3f3bb0126229a05b2912e016970a24c3beba12468d7df6ae
SIZE (Plagman-gamescope-3.8.4_GH0.tar.gz) = 72030
+SHA256 (emersion-libliftoff-b08bbaa_GH0.tar.gz) = bc689419a96d5e2428b77d3cf9e95f532ae89295345bdaf288df24adc4803a04
+SIZE (emersion-libliftoff-b08bbaa_GH0.tar.gz) = 27461
SHA256 (swaywm-wlroots-0.13.0_GH0.tar.gz) = f6bea37fd4a6f5e5f552b83d61adae8c73e64b0bcb9ae0ab464ebcd9309d3cf3
SIZE (swaywm-wlroots-0.13.0_GH0.tar.gz) = 503575
SHA256 (8fae1ff56a62.patch) = 7a636fec88d914047abed0c91268ae1b7779f48e36c74efd37868f2c7ba3955e
@@ -15,5 +17,3 @@ SHA256 (9ebb1c16d3ad.patch) = 8e7c1a46c10d9909d85a673a5a629f293596a5f97d48ad322a
SIZE (9ebb1c16d3ad.patch) = 3540
SHA256 (d59836199ebe.patch) = 40b519ef847b979ba088325cdd7170bed91936b79d845c65d2126b2b25166a1e
SIZE (d59836199ebe.patch) = 2586
-SHA256 (7ad78c179417.patch) = f10a077ac017dd1e08ea63ebfa3c7471ac20df933a7fd66ea6fd9f8ebcb327a9
-SIZE (7ad78c179417.patch) = 1189
diff --git a/x11-wm/gamescope/files/patch-private-libs b/x11-wm/gamescope/files/patch-private-libs
new file mode 100644
index 000000000000..e2961b1e65e9
--- /dev/null
+++ b/x11-wm/gamescope/files/patch-private-libs
@@ -0,0 +1,27 @@
+libliftoff is untagged and has no other consumers. Keep it private to
+gamescope package for now.
+
+--- subprojects/libliftoff/meson.build.orig 2020-05-26 19:30:31 UTC
++++ subprojects/libliftoff/meson.build
+@@ -38,7 +38,7 @@ liftoff_lib = library(
+ include_directories: liftoff_inc,
+ version: meson.project_version(),
+ dependencies: liftoff_deps,
+- install: true,
++ install: not meson.is_subproject(),
+ )
+
+ liftoff = declare_dependency(
+@@ -47,6 +47,7 @@ liftoff = declare_dependency(
+ dependencies: liftoff_deps,
+ )
+
++if not meson.is_subproject()
+ install_headers('include/libliftoff.h')
+
+ pkgconfig = import('pkgconfig')
+@@ -60,3 +61,4 @@ pkgconfig.generate(
+
+ subdir('example')
+ subdir('test')
++endif