aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2022-12-13 19:21:06 +0000
committerThomas Zander <riggs@FreeBSD.org>2022-12-13 21:27:20 +0000
commitce951d576902bed95c66da651dd68d71dca4cd1c (patch)
treecda5735c0c54e1e1a19da8d8951d44ba74d7825a
parentf72163553fc0abbbfcb6f92627444808710a1506 (diff)
downloadports-ce951d576902bed95c66da651dd68d71dca4cd1c.tar.gz
ports-ce951d576902bed95c66da651dd68d71dca4cd1c.zip
multimedia/avidemux: Fix build on i386
Details: - Do not unconditionally (and broken on gcc12) use SSE.
-rw-r--r--multimedia/avidemux/Makefile.common7
-rw-r--r--multimedia/avidemux/files/extra-patch-i386-nosse14
2 files changed, 19 insertions, 2 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index e71a4f3e5de4..5725e2a276fa 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -73,9 +73,12 @@ OPTIONS_DEFAULT+= LAME FAAC AMR X264
# of the stack)
.if ${ARCH} == amd64
CFLAGS+= -fno-omit-frame-pointer
-#MAKE_ENV+= ARCH=x86_64
-#CONFIGURE_ENV+= ARCH=x86_64
.endif
+
+.if ${ARCH} == i386
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-i386-nosse
+.endif
+
CMAKE_ARGS+= -DLIBEXECINFO_INCLUDE_DIR=/usr/include
CMAKE_ARGS+= -DLIBEXECINFO_LIBRARY_DIR=-lexecinfo
diff --git a/multimedia/avidemux/files/extra-patch-i386-nosse b/multimedia/avidemux/files/extra-patch-i386-nosse
new file mode 100644
index 000000000000..fbad75fb59ae
--- /dev/null
+++ b/multimedia/avidemux/files/extra-patch-i386-nosse
@@ -0,0 +1,14 @@
+--- avidemux/common/ADM_audioFilter/src/ADM_soundtouch/STTypes.h.orig 2022-09-17 13:59:16 UTC
++++ avidemux/common/ADM_audioFilter/src/ADM_soundtouch/STTypes.h
+@@ -153,11 +153,6 @@ namespace soundtouch
+ // efficient autovectorization
+ typedef float LONG_SAMPLETYPE;
+
+- #ifdef SOUNDTOUCH_ALLOW_X86_OPTIMIZATIONS
+- // Allow SSE optimizations
+- #define SOUNDTOUCH_ALLOW_SSE 1
+- #endif
+-
+ #endif // SOUNDTOUCH_INTEGER_SAMPLES
+
+ #if ((SOUNDTOUCH_ALLOW_SSE) || (__SSE__) || (SOUNDTOUCH_USE_NEON))