aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:34:23 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:53:58 +0000
commitcf08ab4fffe11f3e31168be094f936f443ed4db5 (patch)
tree163a9a705be8a6c76270b7f6d6fb7c85d9760f4a
parent489eee26b868a637e0f9e3b1b2ce927af7107fe9 (diff)
downloadports-cf08ab4fffe11f3e31168be094f936f443ed4db5.tar.gz
ports-cf08ab4fffe11f3e31168be094f936f443ed4db5.zip
graphics/ming: Replace configure.in patch with upstream one
-rw-r--r--graphics/ming/Makefile2
-rw-r--r--graphics/ming/files/patch-configure.in73
2 files changed, 65 insertions, 10 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 270af1bf4025..0a9095756cf9 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -40,8 +40,6 @@ SHEBANG_FILES= util/cws2fws
OPTIONS_DEFINE= DOCS
-BINARY_ALIAS= freetype-config=true
-
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/ming/ ${STAGEDIR}${PREFIX}/include/ming/blocks/ ${STAGEDIR}${PREFIX}/include/ming/util/
cd ${WRKSRC}/util/ && ${INSTALL_SCRIPT} cws2fws ming-config ${STAGEDIR}${PREFIX}/bin/
diff --git a/graphics/ming/files/patch-configure.in b/graphics/ming/files/patch-configure.in
index fd885cbf0481..1b79fe266905 100644
--- a/graphics/ming/files/patch-configure.in
+++ b/graphics/ming/files/patch-configure.in
@@ -1,13 +1,70 @@
---- configure.in.orig 2021-08-07 06:13:17 UTC
+Obtained from: https://github.com/libming/libming/commit/a89a619e187ebe070db2a1760f3b90489bfff382
+
+--- configure.in.orig 2017-04-07 08:12:56 UTC
+++ configure.in
-@@ -272,8 +272,8 @@ if test "$freetype_support" = "yes"; then
- ft_config="$freetype_config"
- fi
+@@ -247,7 +247,7 @@ AC_CHECK_LIB(X11, XGetImage, XLIB="-lX11", XLIB="")
+ AC_ARG_ENABLE(
+ [freetype],
+-[ --enable-freetype Enable freetype support (default: enabled)],
++[ --disable-freetype Disable freetype support (default: enabled)],
+ [case "${enableval}" in
+ yes) freetype_support=yes ;;
+ no) freetype_support=no ;;
+@@ -257,26 +257,10 @@ freetype_support=yes)
+
+ if test "$freetype_support" = "yes"; then
+ dnl Check for the freetype library
+- AC_ARG_WITH(freetype-config, [ --with-freetype-config=PROG Use FreeType configuration program PROG], freetype_config=$withval, freetype_config=yes)
+- if test "$freetype_config" = "yes"; then
+- AC_PATH_PROG(ft_config,freetype-config,no)
+- if test "$ft_config" = "no"; then
+- echo "To compile ming please install freetype:"
+- echo " as .deb user: sudo apt-get install libfreetype6 libfreetype6-dev"
+- echo ""
+- echo "or disable the freetype configuration option:"
+- echo " --disable-freetype"
+- AC_MSG_ERROR([Could not detect freetype-config!])
+- fi
+- else
+- ft_config="$freetype_config"
+- fi
+-
- FREETYPE_CFLAGS="`$ft_config --cflags`"
- FREETYPE_LIBS="`$ft_config --libs`"
-+ FREETYPE_CFLAGS="`pkg-config freetype2 --cflags`"
-+ FREETYPE_LIBS="`pkg-config freetype2 --libs`"
+-
+- AC_SUBST(FREETYPE_LIBS)
+- AC_SUBST(FREETYPE_CFLAGS)
++ PKG_PROG_PKG_CONFIG
++ PKG_CHECK_MODULES(FREETYPE, freetype2, HAS_FREETYPE=true,
++ AC_MSG_ERROR([Could not find freetype])
++ )
+ fi
+
+ dnl Check for the ungif or gif (new or old) libraries
+@@ -334,9 +318,9 @@ if test -n "${ZLIB}" -a -n "${ZLIB_INC}"; then
+ AC_DEFINE([USE_ZLIB], [1], [Use zlib])
+ fi
+
+-AM_CONDITIONAL(USE_FREETYPE, test x${ft_config} != x)
+-if test -n "${ft_config}"; then
+- AC_DEFINE(USE_FREETYPE, [1], [Use freetype library])
++AM_CONDITIONAL(USE_FREETYPE, test x${HAS_FREETYPE} != x)
++if test x${HAS_FREETYPE} = xtrue ; then
++ AC_DEFINE(USE_FREETYPE, [1], [Use freetype library])
+ fi
+
+ AM_CONDITIONAL(GIFLIB_GIFERRORSTRING, test x"$ac_cv_lib_gif_GifErrorString" = xyes)
+@@ -504,10 +488,10 @@ else
+ echo " ZLIB enabled ($ZLIB)"
+ fi
+
+-if test x"$ft_config" = "x"; then
++if test x"$HAS_FREETYPE" = "x"; then
+ echo " Freetype library disabled"
+ else
+- echo " Freetype library enabled ($ft_config)"
++ echo " Freetype library enabled ($FREETYPE_LIBS)"
+ fi
- AC_SUBST(FREETYPE_LIBS)
- AC_SUBST(FREETYPE_CFLAGS)
+ if test x"$GIFLIB" = "x" -o x"$GIFINC" = "x"; then