aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-03-29 13:57:05 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-03-29 21:20:06 +0000
commitd00d13d7ab37bc28e31e771b424a90ecaa9f06c4 (patch)
treeab3575b3f5f52dfe4b56d6ab487cfa08ad43cfb0
parent6d9a516a14ae94e7dc9a0fec1a70a26893494481 (diff)
downloadports-d00d13d7ab37bc28e31e771b424a90ecaa9f06c4.tar.gz
ports-d00d13d7ab37bc28e31e771b424a90ecaa9f06c4.zip
audio/HVSC-Update: Update to 2.8.8 and switch to fork
Switch to fork which cleans up the code and removes need of patching See https://github.com/laustbn/hvsc-update-tool for more information
-rw-r--r--audio/HVSC-Update/Makefile20
-rw-r--r--audio/HVSC-Update/distinfo5
-rw-r--r--audio/HVSC-Update/files/patch-configure16
3 files changed, 12 insertions, 29 deletions
diff --git a/audio/HVSC-Update/Makefile b/audio/HVSC-Update/Makefile
index 254233f239b6..d01851110369 100644
--- a/audio/HVSC-Update/Makefile
+++ b/audio/HVSC-Update/Makefile
@@ -1,27 +1,25 @@
PORTNAME= HVSC-Update
-PORTVERSION= 2.8.7
+DISTVERSION= 2.8.8
CATEGORIES= audio emulators
-MASTER_SITES= http://www.hvsc.c64.org/download/files/tools/
-DISTNAME= ${PORTNAME:S/-/_/}_Tool_source_${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Update program for the HVSC C= 64 SID tune collection
-WWW= https://www.hvsc.c64.org/
+WWW= https://github.com/laustbn/hvsc-update-tool
-BUILD_DEPENDS= makedepend:devel/makedepend
+USES= cmake compiler:c++17-lang
-GNU_CONFIGURE= yes
-USES= gmake
-USE_CXXSTD= c++98
-WRKSRC= ${WRKDIR}/${PORTNAME:S/-/_/}_Tool_${PORTVERSION:S/.//g}
+USE_GITHUB= yes
+GH_ACCOUNT= laustbn
+GH_PROJECT= hvsc-update-tool
+GH_TAGNAME= ff21266
PORTDOCS= HVS_file_format.txt HVSC_Update.txt SID_file_format.txt
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/hvsc_update_tool
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/Update ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/hvsc_update_tool ${STAGEDIR}${PREFIX}/bin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/audio/HVSC-Update/distinfo b/audio/HVSC-Update/distinfo
index 76270e0fef93..23bc2bfead55 100644
--- a/audio/HVSC-Update/distinfo
+++ b/audio/HVSC-Update/distinfo
@@ -1,2 +1,3 @@
-SHA256 (HVSC_Update_Tool_source_287.tar.gz) = c61177a98c893d3f3f5214edea42b28e16f1af2567cbbf6e639ca9d682b6572c
-SIZE (HVSC_Update_Tool_source_287.tar.gz) = 189813
+TIMESTAMP = 1711228694
+SHA256 (laustbn-hvsc-update-tool-2.8.8-ff21266_GH0.tar.gz) = 9020c605fd5cc0aca1979f4cbe3b00964189789dcbaafd7ad32acabbc3024ae7
+SIZE (laustbn-hvsc-update-tool-2.8.8-ff21266_GH0.tar.gz) = 2339541
diff --git a/audio/HVSC-Update/files/patch-configure b/audio/HVSC-Update/files/patch-configure
deleted file mode 100644
index e7677f6cc011..000000000000
--- a/audio/HVSC-Update/files/patch-configure
+++ /dev/null
@@ -1,16 +0,0 @@
---- configure.orig 2013-09-06 21:05:00 UTC
-+++ configure
-@@ -5168,11 +5168,11 @@ _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--#include <fstream.h>
-+#include <fstream>
- int
- main ()
- {
--ifstream myTest("test",std::ios::binary);
-+std::ifstream myTest("test",std::ios::binary);
- ;
- return 0;
- }