aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-07 12:54:51 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-10 16:19:45 +0000
commitd110b34b93aefc6a810aafdc13c6451e636b3145 (patch)
tree82171e9ef14854eaa90cbd6a88aa59f6d346b6f9
parent54eaa9043d92b513a1b4952b47d7b7a069ba888a (diff)
downloadports-d110b34b93aefc6a810aafdc13c6451e636b3145.tar.gz
ports-d110b34b93aefc6a810aafdc13c6451e636b3145.zip
emulators/mame: fix build on powerpc64*
Move ARM-specific patch to EXTRA_PATCHES to fix build: ../../../../../3rdparty/lzma/C/AesOpt.c:835:9: warning: AES HW_SW stub was used [-W#pragma-messages] ^ ../../../../../3rdparty/lzma/C/AesOpt.c:848:1: error: variable has incomplete type 'void' AES_COMPAT_STUB (AesCbc_Encode) ^ ../../../../../3rdparty/lzma/C/AesOpt.c:844:5: note: expanded from macro 'AES_COMPAT_STUB' AES_FUNC_START(name); \ ^ ../../../../../3rdparty/lzma/C/AesOpt.c:841:10: note: expanded from macro 'AES_FUNC_START' void MY_FAST_CALL name(UInt32 *p, Byte *data, size_t numBlocks) \ ^
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mame/files/extra-patch-3rdparty_lzma_C_AesOpt.c (renamed from emulators/mame/files/patch-3rdparty_lzma_C_AesOpt.c)0
2 files changed, 4 insertions, 0 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 41e0b91df05e..33d455a1d380 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -190,6 +190,10 @@ _TOOLS_MANUALS= -name *.1 -depth 1 -type f -and -not -type d -and -not \
MAKE_ENV+= PTR64=1
.endif
+.if ${ARCH} == aarch64 || ${ARCH} == armv7
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-3rdparty_lzma_C_AesOpt.c
+.endif
+
# Compiling with -pg (PROFILE) causes the linker to run out of memory on i386,
# build with less profiling data:
.if ${ARCH:Mi386}
diff --git a/emulators/mame/files/patch-3rdparty_lzma_C_AesOpt.c b/emulators/mame/files/extra-patch-3rdparty_lzma_C_AesOpt.c
index d9c7100bbe30..d9c7100bbe30 100644
--- a/emulators/mame/files/patch-3rdparty_lzma_C_AesOpt.c
+++ b/emulators/mame/files/extra-patch-3rdparty_lzma_C_AesOpt.c