aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-02-19 13:19:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-02-19 13:25:30 +0000
commitd1384a17a4b16c50711943cf4907460a9bbaabd0 (patch)
treec93849e8c164d6f6af19fec7450934b230766d96
parent448564a0191387481e870ee2c2bfe5011b3a14cf (diff)
downloadports-d1384a17a4b16c50711943cf4907460a9bbaabd0.tar.gz
ports-d1384a17a4b16c50711943cf4907460a9bbaabd0.zip
audio/libmpd: unbreak against clang 15
libmpd-playlist.c:783:10: error: incompatible pointer to integer conversion returning 'void *' from a function with result type 'int' [-Wint-conversion] return NULL; ^~~~
-rw-r--r--audio/libmpd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/audio/libmpd/Makefile b/audio/libmpd/Makefile
index beaf17f02035..2c742eeb51b0 100644
--- a/audio/libmpd/Makefile
+++ b/audio/libmpd/Makefile
@@ -16,6 +16,8 @@ USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CFLAGS+= -Wno-error=int-conversion
+
post-patch:
@${REINPLACE_CMD} -e 's,libmpd-1.0\/libmpd,libmpd,' \
${WRKSRC}/src/Makefile.in