aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2023-10-08 14:52:43 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2023-10-08 14:52:43 +0000
commitd22277621a9d89f2e5ab02a68b40d56c4c37e2b3 (patch)
tree28797ab7de08f810ad48fea54bfcd41165357700
parent8d659482ddfb482224ad9bd6bd3980d36fece95d (diff)
downloadports-d22277621a9d89f2e5ab02a68b40d56c4c37e2b3.tar.gz
ports-d22277621a9d89f2e5ab02a68b40d56c4c37e2b3.zip
www/h2o-devel: move if..endif block after bsd.port.pre.mk
Reported by: dvl Fixes: 79b919312ef2ac04ff54f97adb9872a7357bb344
-rw-r--r--www/h2o-devel/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/h2o-devel/Makefile b/www/h2o-devel/Makefile
index 5cf48e420fd0..2300a41d9502 100644
--- a/www/h2o-devel/Makefile
+++ b/www/h2o-devel/Makefile
@@ -29,9 +29,6 @@ SHEBANG_FILES= share/h2o/start_server
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=OFF \
-DWITH_BUNDLED_SSL=OFF
-.if ${ARCH} == "i386"
-CMAKE_ARGS+= -DWITH_FUSION=OFF
-.endif
CONFLICTS= h2o
@@ -59,6 +56,12 @@ MRUBY_DESC= Build with embedded mruby handler support
MRUBY_USES= bison ruby:build
MRUBY_CMAKE_BOOL= WITH_MRUBY
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+CMAKE_ARGS+= -DWITH_FUSION=OFF
+.endif
+
.include <bsd.port.options.mk>
post-install:
@@ -72,4 +75,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>