aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-07-17 12:03:56 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-07-17 12:20:41 +0000
commitd324e398d355702d1041747a68e0d27ead919c0d (patch)
treea0e6b254ced1b712336a065c0943a11962aaa5de
parent083c714e287cac0eb32f6ebd0235f30d07402248 (diff)
downloadports-d324e398d355702d1041747a68e0d27ead919c0d.tar.gz
ports-d324e398d355702d1041747a68e0d27ead919c0d.zip
x11/arandr: fix broken port
Fix the issue with deprecate call to inspect getargspec. The change was done by upstream in the master branch, but wasn't released yet. PR: 279551 Approved by: maintainer timeout (cherry picked from commit cb8a650b356b0e9458da36e06b99a5fe6a1f1206)
-rw-r--r--x11/arandr/Makefile2
-rw-r--r--x11/arandr/files/patch-screenlayout_gui.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/arandr/Makefile b/x11/arandr/Makefile
index 529a75c55f8b..f07cc047cf71 100644
--- a/x11/arandr/Makefile
+++ b/x11/arandr/Makefile
@@ -1,6 +1,6 @@
PORTNAME= arandr
PORTVERSION= 0.1.10
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 deskutils
MAINTAINER= sbz@FreeBSD.org
diff --git a/x11/arandr/files/patch-screenlayout_gui.py b/x11/arandr/files/patch-screenlayout_gui.py
new file mode 100644
index 000000000000..2beb555f5513
--- /dev/null
+++ b/x11/arandr/files/patch-screenlayout_gui.py
@@ -0,0 +1,11 @@
+--- screenlayout/gui.py.orig 2024-06-06 09:08:21 UTC
++++ screenlayout/gui.py
+@@ -45,7 +45,7 @@
+
+ A first argument called 'self' is passed through.
+ """
+- argnames = inspect.getargspec(function)[0]
++ argnames = inspect.getfullargspec(function)[0]
+ if argnames[0] == 'self':
+ has_self = True
+ argnames.pop(0)