aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-05-22 07:38:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-05-22 07:39:56 +0000
commitd3327765085ba815508be5792efb2505e1f8943c (patch)
treea4aefa2f12367f80affea949dec9d675e38c56af
parent3d662162dfcb3a0da15366ed309a6e987287abb7 (diff)
downloadports-d3327765085ba815508be5792efb2505e1f8943c.tar.gz
ports-d3327765085ba815508be5792efb2505e1f8943c.zip
math/clad: update 1.4 → 1.5
Reported by: portscout
-rw-r--r--math/clad/Makefile3
-rw-r--r--math/clad/distinfo6
-rw-r--r--math/clad/files/patch-CMakeLists.txt19
-rw-r--r--math/clad/pkg-plist5
4 files changed, 21 insertions, 12 deletions
diff --git a/math/clad/Makefile b/math/clad/Makefile
index 1124df4daad1..4187543719d6 100644
--- a/math/clad/Makefile
+++ b/math/clad/Makefile
@@ -1,7 +1,6 @@
PORTNAME= clad
DISTVERSIONPREFIX= v
-DISTVERSION= 1.4
-PORTREVISION= 1
+DISTVERSION= 1.5
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/clad/distinfo b/math/clad/distinfo
index f392eca1a1cf..73891ddb2e0f 100644
--- a/math/clad/distinfo
+++ b/math/clad/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709605257
-SHA256 (vgvassilev-clad-v1.4_GH0.tar.gz) = da5584159499b05d77cfca40baee5d4d212beb269637736fee34d84d2b82d419
-SIZE (vgvassilev-clad-v1.4_GH0.tar.gz) = 969136
+TIMESTAMP = 1716351065
+SHA256 (vgvassilev-clad-v1.5_GH0.tar.gz) = fa044d8a161cbe3ed4e97df0e7ab2b1064a7f3fce7593f0a5d583f4bd866bf90
+SIZE (vgvassilev-clad-v1.5_GH0.tar.gz) = 1030298
diff --git a/math/clad/files/patch-CMakeLists.txt b/math/clad/files/patch-CMakeLists.txt
index 609c98a7523d..a253419c073d 100644
--- a/math/clad/files/patch-CMakeLists.txt
+++ b/math/clad/files/patch-CMakeLists.txt
@@ -1,6 +1,17 @@
---- CMakeLists.txt.orig 2024-02-29 15:28:44 UTC
+--- CMakeLists.txt.orig 2024-05-21 05:35:52 UTC
+++ CMakeLists.txt
-@@ -309,10 +309,14 @@ if (NOT CLAD_BUILD_STATIC_ONLY)
+@@ -317,8 +317,10 @@ if (NOT CLAD_BUILD_STATIC_ONLY)
+ include(GoogleBenchmark)
+ endif(CLAD_ENABLE_BENCHMARKS)
+
++ if (FREEBSD_BUILD_DEMOS)
+ add_subdirectory(demos/ErrorEstimation/CustomModel)
+ add_subdirectory(demos/ErrorEstimation/PrintModel)
++ endif()
+
+ # Change the default compiler to the clang which we run clad upon. Our unittests
+ # need to use a supported by clad compiler. Note that's a huge hack and it is
+@@ -331,8 +333,10 @@ if (NOT CLAD_BUILD_STATIC_ONLY)
string(REPLACE "-fno-lifetime-dse" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
string(REPLACE "-Wno-class-memaccess" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
@@ -8,10 +19,6 @@
add_subdirectory(unittests)
add_subdirectory(test)
+ endif()
-+ if (FREEBSD_BUILD_DEMOS)
- add_subdirectory(demos/ErrorEstimation/CustomModel)
- add_subdirectory(demos/ErrorEstimation/PrintModel)
-+ endif()
# Add benchmarking infrastructure.
if (CLAD_ENABLE_BENCHMARKS)
diff --git a/math/clad/pkg-plist b/math/clad/pkg-plist
index 625e53524eda..af7a92cc2b72 100644
--- a/math/clad/pkg-plist
+++ b/math/clad/pkg-plist
@@ -7,9 +7,12 @@ include/clad/Differentiator/CladConfig.h
include/clad/Differentiator/CladUtils.h
include/clad/Differentiator/Compatibility.h
include/clad/Differentiator/DerivativeBuilder.h
+include/clad/Differentiator/DerivedFnCollector.h
+include/clad/Differentiator/DerivedFnInfo.h
include/clad/Differentiator/DiffMode.h
include/clad/Differentiator/DiffPlanner.h
include/clad/Differentiator/Differentiator.h
+include/clad/Differentiator/DynamicGraph.h
include/clad/Differentiator/ErrorEstimator.h
include/clad/Differentiator/EstimationModel.h
include/clad/Differentiator/ExternalRMVSource.h
@@ -25,6 +28,7 @@ include/clad/Differentiator/ReverseModeForwPassVisitor.h
include/clad/Differentiator/ReverseModeVisitor.h
include/clad/Differentiator/ReverseModeVisitorDirectionKinds.h
include/clad/Differentiator/STLBuiltins.h
+include/clad/Differentiator/Sins.h
include/clad/Differentiator/StmtClone.h
include/clad/Differentiator/Tape.h
include/clad/Differentiator/VectorForwardModeVisitor.h
@@ -33,5 +37,4 @@ include/clad/Differentiator/Version.h
include/clad/Differentiator/VisitorBase.h
include/clad/tools/ClangBackendPlugin.h
include/clad/tools/ClangPlugin.h
-include/clad/tools/DerivedFnInfo.h
lib/clad.so