aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 17:05:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 17:10:40 +0000
commitd3df92fd6a10a1fe31d3bfdfcebeac7a4ed1b347 (patch)
tree17ce352532a25dfaf8c82d62312e6cbd533993a1
parenta522056666f3320a80e50fffe9f89592607514c6 (diff)
downloadports-d3df92fd6a10a1fe31d3bfdfcebeac7a4ed1b347.tar.gz
ports-d3df92fd6a10a1fe31d3bfdfcebeac7a4ed1b347.zip
textproc/py-furo: Update to 2022.9.29
-rw-r--r--textproc/py-furo/Makefile4
-rw-r--r--textproc/py-furo/distinfo10
-rw-r--r--textproc/py-furo/files/setup.py4
3 files changed, 9 insertions, 9 deletions
diff --git a/textproc/py-furo/Makefile b/textproc/py-furo/Makefile
index e753a9bf6b21..962fd1104eaa 100644
--- a/textproc/py-furo/Makefile
+++ b/textproc/py-furo/Makefile
@@ -1,5 +1,5 @@
PORTNAME= furo
-PORTVERSION= 2022.6.21
+PORTVERSION= 2022.9.29
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP \
LOCAL/sunpoet:static
@@ -15,7 +15,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.7:textproc/py-pygments@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx>=4.0,1<6.0,1:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx-basic-ng>=0:textproc/py-sphinx-basic-ng@${PY_FLAVOR}
diff --git a/textproc/py-furo/distinfo b/textproc/py-furo/distinfo
index c0a578b5a06c..36a7d02c695e 100644
--- a/textproc/py-furo/distinfo
+++ b/textproc/py-furo/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1655851769
-SHA256 (furo-2022.6.21.tar.gz) = 9aa983b7488a4601d13113884bfb7254502c8729942e073a0acb87a5512af223
-SIZE (furo-2022.6.21.tar.gz) = 1671981
-SHA256 (furo-2022.6.21-static.tar.gz) = 1273d170c5be84da691284376530a5d32e28217172df5f57cf958957252475ae
-SIZE (furo-2022.6.21-static.tar.gz) = 175104
+TIMESTAMP = 1664767986
+SHA256 (furo-2022.9.29.tar.gz) = d4238145629c623609c2deb5384f8d036e2a1ee2a101d64b67b4348112470dbd
+SIZE (furo-2022.9.29.tar.gz) = 1675250
+SHA256 (furo-2022.9.29-static.tar.gz) = c2ad1ac4f6f7c73b3f467edef131f7ce13bd3576eb40315376469a168b60c8fa
+SIZE (furo-2022.9.29-static.tar.gz) = 176128
diff --git a/textproc/py-furo/files/setup.py b/textproc/py-furo/files/setup.py
index 1b7b25890ab5..a6f7a73fef68 100644
--- a/textproc/py-furo/files/setup.py
+++ b/textproc/py-furo/files/setup.py
@@ -27,7 +27,7 @@ package_dir = \
{'': 'src'}
install_requires = \
-['beautifulsoup4', 'sphinx ~= 4.0', 'pygments ~= 2.7']
+['beautifulsoup4', 'sphinx >= 4.0,<6.0', 'sphinx-basic-ng', 'pygments >= 2.7']
entry_points = \
{'sphinx.html_themes': ['furo = furo']}
@@ -43,5 +43,5 @@ setup(name='furo',
package_dir=package_dir,
install_requires=install_requires,
entry_points=entry_points,
- python_requires='>=3.6',
+ python_requires='>=3.7',
)