aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2024-05-22 20:21:39 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2024-05-22 20:27:22 +0000
commitd40b7417ee03273041385e9fab84638c1a3f4eea (patch)
tree71fa0683605b77185324a4e2c899b881470ee00d
parent3dae89d81ed53e92b56db78a4e41787f5f312934 (diff)
downloadports-d40b7417ee03273041385e9fab84638c1a3f4eea.tar.gz
ports-d40b7417ee03273041385e9fab84638c1a3f4eea.zip
databases/xtrabackup80: fix handling of dependencies
Fix build after latest changes: do not override *_DEPENDS added with USES clause.
-rw-r--r--databases/xtrabackup80/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/databases/xtrabackup80/Makefile b/databases/xtrabackup80/Makefile
index 7815c90e5e5e..7004a9812a23 100644
--- a/databases/xtrabackup80/Makefile
+++ b/databases/xtrabackup80/Makefile
@@ -55,23 +55,23 @@ LDFLAGS_i386= -latomic -Wl,-rpath=${PREFIX}/lib/gcc${GCCVER} -Wl,-rpath=${PREFIX
PLIST= ${PKGDIR}/pkg-plist.i386
USE_LDCONFIG= ${PREFIX}/lib/private
-BUILD_DEPENDS= c++${GCCVER}:lang/gcc${GCCVER}
-LIB_DEPENDS= libcurl.so:ftp/curl \
+BUILD_DEPENDS+= c++${GCCVER}:lang/gcc${GCCVER}
+LIB_DEPENDS+= libcurl.so:ftp/curl \
libev.so:devel/libev \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error \
libunwind.so:devel/libunwind
-RUN_DEPENDS= ${PREFIX}/lib/gcc${GCCVER}/libatomic.so.1:lang/gcc${GCCVER}
+RUN_DEPENDS+= ${PREFIX}/lib/gcc${GCCVER}/libatomic.so.1:lang/gcc${GCCVER}
.for component in EDITLINE ICU LIBEVENT PROTOBUF RAPIDJSON ZSTD
CMAKE_ARGS+= -DWITH_${component}:STRING=bundled
.endfor
.else
-BUILD_DEPENDS= protobuf>=3.0:devel/protobuf \
+BUILD_DEPENDS+= protobuf>=3.0:devel/protobuf \
rapidjson>=1.1.0:devel/rapidjson \
libevent>=2.1:devel/libevent
-LIB_DEPENDS= libcurl.so:ftp/curl \
+LIB_DEPENDS+= libcurl.so:ftp/curl \
libev.so:devel/libev \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error \