aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2021-12-20 13:19:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2021-12-20 14:02:27 +0000
commitd4c09351b85fa9f3fce34923ed1e8b1cddb0bd38 (patch)
treeeb4f1d10bf3fd049a18989d9e1bb5f7358083228
parentd2d0d9c1e32af4a8c430961ea87dfe2ee2a71c4c (diff)
downloadports-d4c09351b85fa9f3fce34923ed1e8b1cddb0bd38.tar.gz
ports-d4c09351b85fa9f3fce34923ed1e8b1cddb0bd38.zip
security/shibboleth-sp: Silence bogus apache 1.3 warning
PR: 260482 Submitted by: Craig Leres
-rw-r--r--security/shibboleth-sp/Makefile1
-rw-r--r--security/shibboleth-sp/files/patch-apache__mod_shib_cpp26
2 files changed, 27 insertions, 0 deletions
diff --git a/security/shibboleth-sp/Makefile b/security/shibboleth-sp/Makefile
index 45213b136e7e..b2975708b058 100644
--- a/security/shibboleth-sp/Makefile
+++ b/security/shibboleth-sp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= shibboleth-sp
PORTVERSION= 3.3.0
+PORTREVISION= 1
CATEGORIES= security www
MASTER_SITES= http://shibboleth.net/downloads/service-provider/${PORTVERSION}/
diff --git a/security/shibboleth-sp/files/patch-apache__mod_shib_cpp b/security/shibboleth-sp/files/patch-apache__mod_shib_cpp
new file mode 100644
index 000000000000..681b195a738a
--- /dev/null
+++ b/security/shibboleth-sp/files/patch-apache__mod_shib_cpp
@@ -0,0 +1,26 @@
+From: Scott Cantor <cantor.2@osu.edu>
+Date: Tue, 30 Nov 2021 17:38:09 +0000 (-0500)
+Subject: SSPCPP-948 - mod_shib warning about Apache 1.3 in log
+X-Git-Url: https://git.shibboleth.net/view/?p=cpp-sp.git;a=commitdiff_plain;h=7b5c7aced15c0be5404bcba0bcec4c586323fba9
+
+SSPCPP-948 - mod_shib warning about Apache 1.3 in log
+
+https://shibboleth.atlassian.net/browse/SSPCPP-948
+---
+
+diff --git a/apache/mod_shib.cpp b/apache/mod_shib.cpp
+index 6b1dc676..1a1f2543 100644
+--- apache/mod_shib.cpp
++++ apache/mod_shib.cpp
+@@ -1983,10 +1983,10 @@ extern "C" void shib_child_init(apr_pool_t* p, server_rec* s)
+ // Initialize runtime components.
+
+ ap_log_error(APLOG_MARK, APLOG_INFO|APLOG_NOERRNO, SH_AP_R(s), "child_init: mod_shib initializing in pid (%d)", (int)getpid());
+- ap_log_error(APLOG_MARK, APLOG_WARNING|APLOG_NOERRNO, SH_AP_R(s), "DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+");
+
+ // 2.x versions have already initialized the libraries.
+ #ifdef SHIB_APACHE_13
++ ap_log_error(APLOG_MARK, APLOG_WARNING|APLOG_NOERRNO, SH_AP_R(s), "DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+");
+ if (g_Config) {
+ ap_log_error(APLOG_MARK, APLOG_ERR|APLOG_NOERRNO, SH_AP_R(s), "child_init: mod_shib already initialized, exiting");
+ exit(1);