aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 22:04:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 22:07:00 +0000
commitd4ef0c9455048cd06382ca189bb256a4c1a8c313 (patch)
tree327688942e964b59462428b63d16896d5adadd57
parent4186d3b14c588ce66b717d57e05a6bcd82a4ca78 (diff)
downloadports-d4ef0c9455048cd06382ca189bb256a4c1a8c313.tar.gz
ports-d4ef0c9455048cd06382ca189bb256a4c1a8c313.zip
security/rubygem-net-scp1: Add rubygem-net-scp1 1.2.1 (copied from rubygem-net-scp)
- Add LICENSE_FILE - Add PORTSCOUT
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-net-scp1/Makefile22
-rw-r--r--security/rubygem-net-scp1/distinfo3
-rw-r--r--security/rubygem-net-scp1/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0c6d4ffaa076..0372e6d91510 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1094,6 +1094,7 @@
SUBDIR += rubygem-metasploit_payloads-mettle
SUBDIR += rubygem-nessus_rest
SUBDIR += rubygem-net-scp
+ SUBDIR += rubygem-net-scp1
SUBDIR += rubygem-net-sftp
SUBDIR += rubygem-net-ssh
SUBDIR += rubygem-net-ssh-gateway
diff --git a/security/rubygem-net-scp1/Makefile b/security/rubygem-net-scp1/Makefile
new file mode 100644
index 000000000000..57c547de5db1
--- /dev/null
+++ b/security/rubygem-net-scp1/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= net-scp
+PORTVERSION= 1.2.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 1
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Non-interactive SCP processing
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^1\.
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-net-scp1/distinfo b/security/rubygem-net-scp1/distinfo
new file mode 100644
index 000000000000..4fd80d76d872
--- /dev/null
+++ b/security/rubygem-net-scp1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626645800
+SHA256 (rubygem/net-scp-1.2.1.gem) = 928ca046246bdbfe304313c903bab95e7b711938ceff4a2c896b91ab59c6122c
+SIZE (rubygem/net-scp-1.2.1.gem) = 32768
diff --git a/security/rubygem-net-scp1/pkg-descr b/security/rubygem-net-scp1/pkg-descr
new file mode 100644
index 000000000000..4a75e84dbfde
--- /dev/null
+++ b/security/rubygem-net-scp1/pkg-descr
@@ -0,0 +1,10 @@
+Net::SCP is a pure-Ruby implementation of the SCP protocol. This operates over
+SSH (and requires the Net::SSH library), and allows files and directory trees
+to copied to and from a remote server.
+
+* Transfer files or entire directory trees to or from a remote host via SCP
+* Can preserve file attributes across transfers
+* Can download files in-memory, or direct-to-disk
+* Support for SCP URI's, and OpenURI
+
+WWW: https://github.com/net-ssh/net-scp