aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-16 05:54:32 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-03-16 05:54:32 +0000
commitd5173cf69d95f13acfc276a490f1079a4717d21e (patch)
treea9a61929afbcfe7b4db27ccc991cbfb175321b67
parentad96d9888ffd3892e22636c2eca7609a5bf0cc90 (diff)
downloadports-d5173cf69d95f13acfc276a490f1079a4717d21e.tar.gz
ports-d5173cf69d95f13acfc276a490f1079a4717d21e.zip
devel/py-hatch-nodejs-version: New port
This package provides two Hatch plugins: * version source plugin that reads/writes the package version from the version field of the Node.js package.json file. * metadata hook plugin that reads PEP 621 metadata from the Node.js package.json file. WWW: https://github.com/agoose77/hatch-nodejs-version
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hatch-nodejs-version/Makefile25
-rw-r--r--devel/py-hatch-nodejs-version/distinfo3
-rw-r--r--devel/py-hatch-nodejs-version/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 320303eab7c4..c626e4ae13c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4688,6 +4688,7 @@
SUBDIR += py-hash_ring
SUBDIR += py-hatch
SUBDIR += py-hatch-fancy-pypi-readme
+ SUBDIR += py-hatch-nodejs-version
SUBDIR += py-hatch-vcs
SUBDIR += py-hatchling
SUBDIR += py-heapdict
diff --git a/devel/py-hatch-nodejs-version/Makefile b/devel/py-hatch-nodejs-version/Makefile
new file mode 100644
index 000000000000..7168be6e6c21
--- /dev/null
+++ b/devel/py-hatch-nodejs-version/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= hatch-nodejs-version
+DISTVERSION= 0.3.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= hatch_nodejs_version-${DISTVERSION}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Hatch plugin for versioning from a package.json file
+WWW= https://github.com/agoose77/hatch-nodejs-version
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist pep517 pytest
+
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-hatch-nodejs-version/distinfo b/devel/py-hatch-nodejs-version/distinfo
new file mode 100644
index 000000000000..17117c0f4f9c
--- /dev/null
+++ b/devel/py-hatch-nodejs-version/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1671531749
+SHA256 (hatch_nodejs_version-0.3.1.tar.gz) = 0e55fd713d92c5c1ccfee778efecaa780fd8bcd276d4ca7aff9f6791f6f76d9c
+SIZE (hatch_nodejs_version-0.3.1.tar.gz) = 14347
diff --git a/devel/py-hatch-nodejs-version/pkg-descr b/devel/py-hatch-nodejs-version/pkg-descr
new file mode 100644
index 000000000000..7c13c5d0cf2e
--- /dev/null
+++ b/devel/py-hatch-nodejs-version/pkg-descr
@@ -0,0 +1,7 @@
+This package provides two Hatch plugins:
+
+* version source plugin that reads/writes the package version from the version
+ field of the Node.js package.json file.
+
+* metadata hook plugin that reads PEP 621 metadata from the Node.js
+ package.json file.