aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-04-28 06:12:37 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-04-29 07:07:38 +0000
commitd574ff43f5f161403e925c5a99564329bb50d246 (patch)
tree624a41ba564bdb56a4591a140046c367b0471629
parent65aafcaa1fafc6b933d0fd258636eae9c5b83f68 (diff)
downloadports-d574ff43f5f161403e925c5a99564329bb50d246.tar.gz
ports-d574ff43f5f161403e925c5a99564329bb50d246.zip
lang/gcc10: Update to the GCC 10.3 release
This is the third release in the GCC 10 series. It fixes some 94 bugs and already includes three patches we've been carrying locally which we thus can remove: - files/patch-aarch64-c++98-fix - files/patch-libcpp_lex.c - files/patch-powerpc64le
-rw-r--r--lang/gcc10/Makefile3
-rw-r--r--lang/gcc10/distinfo6
-rw-r--r--lang/gcc10/files/patch-aarch64-c++98-fix32
-rw-r--r--lang/gcc10/files/patch-libcpp_lex.c25
-rw-r--r--lang/gcc10/files/patch-powerpc64le77
5 files changed, 4 insertions, 139 deletions
diff --git a/lang/gcc10/Makefile b/lang/gcc10/Makefile
index d28556e821d2..22f6022bebfc 100644
--- a/lang/gcc10/Makefile
+++ b/lang/gcc10/Makefile
@@ -1,8 +1,7 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
PORTNAME= gcc
-PORTVERSION= 10.2.0
-PORTREVISION= 1
+PORTVERSION= 10.3.0
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc10/distinfo b/lang/gcc10/distinfo
index b8233036ac8c..0463ec6b5b2b 100644
--- a/lang/gcc10/distinfo
+++ b/lang/gcc10/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596200916
-SHA256 (gcc-10.2.0.tar.xz) = b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c
-SIZE (gcc-10.2.0.tar.xz) = 75004144
+TIMESTAMP = 1619249722
+SHA256 (gcc-10.3.0.tar.xz) = 64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344
+SIZE (gcc-10.3.0.tar.xz) = 76692288
diff --git a/lang/gcc10/files/patch-aarch64-c++98-fix b/lang/gcc10/files/patch-aarch64-c++98-fix
deleted file mode 100644
index ec6b32b63c0c..000000000000
--- a/lang/gcc10/files/patch-aarch64-c++98-fix
+++ /dev/null
@@ -1,32 +0,0 @@
-Temporary back port from the GCC 10 branch until GCC 10.3 releases.
-
-commit 3b777ab44049e06dc0825f86a8310673cdb6498c
-Author: Francois-Xavier Coudert <fxcoudert@gcc.gnu.org>
-Date: Mon Dec 21 21:06:59 2020 +0000
-
- aarch64 : Remove the use of a C++11 brace-init-list.
-
- Instead of using a brace-init-list, set up the member values
- manually.
-
- gcc/
-
- * config/aarch64/aarch64-builtins.c
- (aarch64_init_memtag_builtins): Manually initialize instead
- of using a C++11 brace-init-list.
-
---- UTC
---- gcc/config/aarch64/aarch64-builtins.c
-+++ gcc/config/aarch64/aarch64-builtins.c
-@@ -1223,8 +1223,9 @@ aarch64_init_memtag_builtins (void)
- = aarch64_general_add_builtin ("__builtin_aarch64_memtag_"#N, \
- T, AARCH64_MEMTAG_BUILTIN_##F); \
- aarch64_memtag_builtin_data[AARCH64_MEMTAG_BUILTIN_##F - \
-- AARCH64_MEMTAG_BUILTIN_START - 1] = \
-- {T, CODE_FOR_##I};
-+ AARCH64_MEMTAG_BUILTIN_START - 1].ftype = T; \
-+ aarch64_memtag_builtin_data[AARCH64_MEMTAG_BUILTIN_##F - \
-+ AARCH64_MEMTAG_BUILTIN_START - 1].icode = CODE_FOR_##I;
-
- fntype = build_function_type_list (ptr_type_node, ptr_type_node,
- uint64_type_node, NULL);
diff --git a/lang/gcc10/files/patch-libcpp_lex.c b/lang/gcc10/files/patch-libcpp_lex.c
deleted file mode 100644
index 05ad28872d11..000000000000
--- a/lang/gcc10/files/patch-libcpp_lex.c
+++ /dev/null
@@ -1,25 +0,0 @@
-This is
-
- commit cd547f0ddcd3a54e5b73bcda5ac0f0c46808db8b
- Author: Jakub Jelinek <jakub@redhat.com>
- Date: Sat Sep 26 10:07:41 2020 +0200
-
-which is on the GCC 10 release branch and thus part of lang/gcc10-devel;
-we should automatically get it with GCC 10.3.
-
---- libcpp/lex.c.orig 2020-11-02 10:24:50 UTC
-+++ libcpp/lex.c
-@@ -531,11 +531,11 @@ init_vectorized_lexer (void)
- search_line_fast = impl;
- }
-
--#elif defined(_ARCH_PWR8) && defined(__ALTIVEC__)
-+#elif (GCC_VERSION >= 4005) && defined(_ARCH_PWR8) && defined(__ALTIVEC__)
-
- /* A vection of the fast scanner using AltiVec vectorized byte compares
- and VSX unaligned loads (when VSX is available). This is otherwise
-- the same as the pre-GCC 5 version. */
-+ the same as the AltiVec version. */
-
- ATTRIBUTE_NO_SANITIZE_UNDEFINED
- static const uchar *
diff --git a/lang/gcc10/files/patch-powerpc64le b/lang/gcc10/files/patch-powerpc64le
deleted file mode 100644
index 6973c9396e09..000000000000
--- a/lang/gcc10/files/patch-powerpc64le
+++ /dev/null
@@ -1,77 +0,0 @@
---- gcc/config.gcc.orig 2020-07-23 06:35:17 UTC
-+++ gcc/config.gcc
-@@ -2868,6 +2868,10 @@ powerpc*-*-freebsd*)
- extra_options="${extra_options} rs6000/sysv4.opt"
- tmake_file="rs6000/t-fprules rs6000/t-ppcos ${tmake_file} rs6000/t-ppccomm"
- case ${target} in
-+ powerpc*le-*-*)
-+ tm_file="${tm_file} rs6000/sysv4le.h" ;;
-+ esac
-+ case ${target} in
- powerpc64*)
- tm_file="${tm_file} rs6000/default64.h rs6000/freebsd64.h"
- tmake_file="${tmake_file} rs6000/t-freebsd64"
---- gcc/config/rs6000/freebsd64.h.orig 2020-07-23 06:35:17 UTC
-+++ gcc/config/rs6000/freebsd64.h
-@@ -51,11 +51,10 @@ extern int dot_symbols;
- #define SET_CMODEL(opt) do {} while (0)
- #endif
-
--/* Until now the 970 is the only Processor where FreeBSD 64-bit runs on. */
- #undef PROCESSOR_DEFAULT
--#define PROCESSOR_DEFAULT PROCESSOR_POWER4
-+#define PROCESSOR_DEFAULT PROCESSOR_PPC7450
- #undef PROCESSOR_DEFAULT64
--#define PROCESSOR_DEFAULT64 PROCESSOR_POWER4
-+#define PROCESSOR_DEFAULT64 PROCESSOR_POWER8
-
- /* We don't need to generate entries in .fixup, except when
- -mrelocatable or -mrelocatable-lib is given. */
-@@ -158,8 +157,8 @@ extern int dot_symbols;
- #define ASM_SPEC64 "-a64"
-
- #define ASM_SPEC_COMMON "%(asm_cpu) \
--%{,assembler|,assembler-with-cpp: %{mregnames} %{mno-regnames}} \
--%{mlittle} %{mlittle-endian} %{mbig} %{mbig-endian}"
-+%{,assembler|,assembler-with-cpp: %{mregnames} %{mno-regnames}}" \
-+ ENDIAN_SELECT(" -mbig", " -mlittle", DEFAULT_ASM_ENDIAN)
-
- #undef SUBSUBTARGET_EXTRA_SPECS
- #define SUBSUBTARGET_EXTRA_SPECS \
-@@ -181,9 +180,15 @@ extern int dot_symbols;
- %{static:-Bstatic}} \
- %{symbolic:-Bsymbolic}"
-
-+#undef DEFAULT_ASM_ENDIAN
- #define LINK_OS_FREEBSD_SPEC32 "-melf32ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF
--
-+#if (TARGET_DEFAULT & MASK_LITTLE_ENDIAN)
-+#define DEFAULT_ASM_ENDIAN " -mlittle"
-+#define LINK_OS_FREEBSD_SPEC64 "-melf64lppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF
-+#else
-+#define DEFAULT_ASM_ENDIAN " -mbig"
- #define LINK_OS_FREEBSD_SPEC64 "-melf64ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF
-+#endif
-
- #undef MULTILIB_DEFAULTS
- #define MULTILIB_DEFAULTS { "m64" }
---- gcc/configure.orig 2020-07-23 06:35:17 UTC
-+++ gcc/configure
-@@ -29398,13 +29398,16 @@ $as_echo "#define HAVE_LD_PPC_GNU_ATTR_LONG_DOUBLE 1"
- esac
-
- case "$target:$tm_file" in
-- powerpc64-*-freebsd* | powerpc64*-*-linux* | powerpc*-*-linux*rs6000/biarch64.h*)
-+ powerpc64*-*-freebsd* | powerpc64*-*-linux* | powerpc*-*-linux*rs6000/biarch64.h*)
- case "$target" in
- *le-*-linux*)
- emul_name="-melf64lppc"
- ;;
- *-*-linux*)
- emul_name="-melf64ppc"
-+ ;;
-+ *le-*-freebsd*)
-+ emul_name="-melf64lppc_fbsd"
- ;;
- *-*-freebsd*)
- emul_name="-melf64ppc_fbsd"