aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2022-11-15 15:34:39 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2022-11-15 16:06:12 +0000
commitd5852a2decba2f80b1097692de18b09f5fa4c37b (patch)
tree5a269df4491847bb3fdfc46ddd07fcd98dc83b3f
parent287db69a8e7299e0984890e416fed4e30e406556 (diff)
downloadports-d5852a2decba2f80b1097692de18b09f5fa4c37b.tar.gz
ports-d5852a2decba2f80b1097692de18b09f5fa4c37b.zip
net-im/dino: Fix building with UPLOAD option
The CMake option was incorrectly applied in the previous commit PR: 267739 Reported by: Ivan Rozhuk <rozhuk dot im at gmail dot com>
-rw-r--r--net-im/dino/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net-im/dino/Makefile b/net-im/dino/Makefile
index fc32583fffa0..1f9226502f51 100644
--- a/net-im/dino/Makefile
+++ b/net-im/dino/Makefile
@@ -44,7 +44,6 @@ UPLOAD_DESC= HTTP file upload plugin
ICE_LIB_DEPENDS= libnice.so:net-im/libnice \
libgnutls.so:security/gnutls
ICE_VARS= ENABLED_PLUGINS+=ice
-ICE_CMAKE_ON= -DSOUP_VERSION:INT=2
ICE_VARS_OFF= DISABLED_PLUGINS+=ice
RTP_LIB_DEPENDS= libgnutls.so:security/gnutls \
libwebrtc-audio-processing-1.so:audio/webrtc-audio-processing
@@ -58,6 +57,7 @@ OMEMO_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
OMEMO_VARS= ENABLED_PLUGINS+=omemo
OMEMO_CMAKE_BOOL= BUILD_LIBSIGNAL_IN_TREE
OMEMO_VARS_OFF= DISABLED_PLUGINS+=omemo
+UPLOAD_CMAKE_ON= -DSOUP_VERSION:INT=2
UPLOAD_VARS= ENABLED_PLUGINS+=http-files
UPLOAD_VARS_OFF= DISABLED_PLUGINS+=http-files
GNUPG_LIB_DEPENDS= libgpgme.so:security/gpgme