aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-07-02 12:49:16 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-07-09 22:08:08 +0000
commitd58c19e0f1a684ed9c8c16057056cb4d0daa58ec (patch)
treeb4cfdee25fe4aea012a879af6e2c7a149b3efa71
parent7684f850fde165b5cc6e9df067d2fc0e1a3a03ff (diff)
downloadports-d58c19e0f1a684ed9c8c16057056cb4d0daa58ec.tar.gz
ports-d58c19e0f1a684ed9c8c16057056cb4d0daa58ec.zip
graphics/gimp-lensfun-plugin: make compatible with exiv2 0.28
PR: 272311
-rw-r--r--graphics/gimp-lensfun-plugin/Makefile17
-rw-r--r--graphics/gimp-lensfun-plugin/files/patch-src_gimplensfun.cpp20
2 files changed, 34 insertions, 3 deletions
diff --git a/graphics/gimp-lensfun-plugin/Makefile b/graphics/gimp-lensfun-plugin/Makefile
index b62db7ac5dcf..f49759bd0d6c 100644
--- a/graphics/gimp-lensfun-plugin/Makefile
+++ b/graphics/gimp-lensfun-plugin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lensfun
DISTVERSION= 0.2.5-dev
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= gimp-
PKGNAMESUFFIX= -plugin
@@ -14,15 +15,27 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/exiv2.pc:graphics/exiv2 \
${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:graphics/gimp-app \
${LOCALBASE}/libdata/pkgconfig/lensfun.pc:graphics/lensfun
+
+LIB_DEPENDS+= libatk-1.0.so:accessibility/at-spi2-core \
+ libbabl-0.1.so:x11/babl \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgegl-0.4.so:graphics/gegl \
+ libgegl-npd-0.4.so:graphics/gegl \
+ libharfbuzz.so:print/harfbuzz \
+ libjson-glib-1.0.so:devel/json-glib
+
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= compiler:c++11-lang gmake pkgconfig
+USES= compiler:c++11-lang gettext-runtime gmake gnome pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= seebk
GH_PROJECT= GIMP-Lensfun
GH_TAGNAME= c5eaf97
+USE_GNOME+= cairo gdkpixbuf2 glib20 gtk20 pango
+
PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
PLUGINS= gimp-lensfun
@@ -35,8 +48,6 @@ post-patch:
@${REINPLACE_CMD} \
-e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
${WRKSRC}/Makefile
-# CCI support has been removed from recent versions of lensfun
- @${REINPLACE_CMD} -e '/CCI/d' ${WRKSRC}/src/gimplensfun.cpp
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
diff --git a/graphics/gimp-lensfun-plugin/files/patch-src_gimplensfun.cpp b/graphics/gimp-lensfun-plugin/files/patch-src_gimplensfun.cpp
new file mode 100644
index 000000000000..a095cdab410b
--- /dev/null
+++ b/graphics/gimp-lensfun-plugin/files/patch-src_gimplensfun.cpp
@@ -0,0 +1,20 @@
+--- src/gimplensfun.cpp.orig 2023-07-02 12:36:07 UTC
++++ src/gimplensfun.cpp
+@@ -1034,7 +1034,7 @@ static void process_image (GimpDrawable *drawable) {
+ //
+ static int read_opts_from_exif(const char *filename) {
+
+- Exiv2::Image::AutoPtr Exiv2image;
++ Exiv2::Image::UniquePtr Exiv2image;
+ Exiv2::ExifData exifData;
+
+ const lfCamera **cameras = 0;
+@@ -1062,7 +1062,7 @@ static int read_opts_from_exif(const char *filename) {
+ return -1;
+ }
+ }
+- catch (Exiv2::AnyError& e) {
++ catch (Exiv2::Error& e) {
+ if (DEBUG) {
+ g_print ("exception on reading data. \n");
+ }