aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2023-06-05 19:17:22 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2023-06-19 18:49:17 +0000
commitd5d32f2cdef10465226814f34e12e3e5e4a1b2ca (patch)
tree8de13cdb26928869ebdcd80a68c601806997b980
parentd82582a86eefc39f9eefb94efc5c54a3d8d94f82 (diff)
downloadports-d5d32f2cdef10465226814f34e12e3e5e4a1b2ca.tar.gz
ports-d5d32f2cdef10465226814f34e12e3e5e4a1b2ca.zip
PySide6: Python biding for Qt6
Add devel/pyside6* and devel/shiboken6 PySide6 is the official Python module from the Qt for Python project, which provides access to the complete Qt 6.0+ framework.
-rw-r--r--devel/Makefile3
-rw-r--r--devel/pyside6-tools/Makefile42
-rw-r--r--devel/pyside6-tools/distinfo3
-rw-r--r--devel/pyside6-tools/pkg-descr4
-rw-r--r--devel/pyside6-tools/pkg-plist37
-rw-r--r--devel/pyside6/Makefile46
-rw-r--r--devel/pyside6/distinfo3
-rw-r--r--devel/pyside6/files/patch-cmake_Macros_PySideModules.cmake11
-rw-r--r--devel/pyside6/pkg-descr5
-rw-r--r--devel/pyside6/pkg-plist246
-rw-r--r--devel/shiboken6/Makefile46
-rw-r--r--devel/shiboken6/distinfo3
-rw-r--r--devel/shiboken6/files/patch-data_shiboken6.pc.in9
-rw-r--r--devel/shiboken6/files/patch-doc_CMakeLists.txt9
-rw-r--r--devel/shiboken6/files/patch-sources_shiboken6_libshiboken_helper.h11
-rw-r--r--devel/shiboken6/pkg-descr7
-rw-r--r--devel/shiboken6/pkg-plist57
17 files changed, 542 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b375010002a6..a589983ef041 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5852,6 +5852,8 @@
SUBDIR += pyotherside-qt5
SUBDIR += pyside2
SUBDIR += pyside2-tools
+ SUBDIR += pyside6
+ SUBDIR += pyside6-tools
SUBDIR += pystring
SUBDIR += pysvn
SUBDIR += pythontidy
@@ -7506,6 +7508,7 @@
SUBDIR += shflags
SUBDIR += shfmt
SUBDIR += shiboken2
+ SUBDIR += shiboken6
SUBDIR += shmap
SUBDIR += shroud
SUBDIR += shtk
diff --git a/devel/pyside6-tools/Makefile b/devel/pyside6-tools/Makefile
new file mode 100644
index 000000000000..c5270749ee57
--- /dev/null
+++ b/devel/pyside6-tools/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= pyside6-tools
+DISTVERSION= ${QT6_VERSION}
+CATEGORIES= devel
+MASTER_SITES= QT/official_releases/QtForPython/shiboken6/PySide6-${DISTVERSION}-src
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyside-setup-opensource-src-${DISTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Pyside6 development tools
+
+LICENSE= BSD3CLAUSE GPLv2
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers \
+ git>0:devel/git
+LIB_DEPENDS= libshiboken6.abi${PYTHON_MAJOR_VER}.so:devel/shiboken6@${PY_FLAVOR} \
+ libpyside6.abi${PYTHON_MAJOR_VER}.so:devel/pyside6@${PY_FLAVOR} \
+ libxkbcommon.so:x11/libxkbcommon \
+ libzstd.so:archivers/zstd \
+ libLLVM-${LLVM_DEFAULT}.so:devel/llvm${LLVM_DEFAULT}
+
+USES= cmake gl python:3.5+ qt:6 shebangfix tar:xz xorg
+USE_GL= gl
+USE_PYTHON= flavors
+USE_QT= base tools languageserver declarative
+
+SHEBANG_FILES= pyside_tool.py qtpy2cpp_lib/tests/baseline/basic_test.py
+
+CMAKE_ARGS+= -DQT6_INSTALL_PREFIX=${LOCALBASE}/lib/qt6 \
+ -DCMAKE_EXECUTABLE_SUFFIX=6
+
+PLIST_FILES= bin/pyside_tool.py
+
+.include <bsd.port.pre.mk>
+
+WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION}/sources/pyside-tools
+
+#.if ${ARCH} == amd64 || ${ARCH} == i386
+#USE_QT+= webengine
+#.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pyside6-tools/distinfo b/devel/pyside6-tools/distinfo
new file mode 100644
index 000000000000..bf53dbd1c7a2
--- /dev/null
+++ b/devel/pyside6-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685944863
+SHA256 (pyside-setup-opensource-src-6.4.2.tar.xz) = 1ec9d0936332efd229650cf10fed36cadddff7a613a2ea6e897de4d504c1b505
+SIZE (pyside-setup-opensource-src-6.4.2.tar.xz) = 8759528
diff --git a/devel/pyside6-tools/pkg-descr b/devel/pyside6-tools/pkg-descr
new file mode 100644
index 000000000000..4f69e1599e9e
--- /dev/null
+++ b/devel/pyside6-tools/pkg-descr
@@ -0,0 +1,4 @@
+PySide6 is the Python Qt 6 bindings project. This package contains the
+PySide6 development tools.
+
+WWW: https://wiki.qt.io/Qt_for_Python
diff --git a/devel/pyside6-tools/pkg-plist b/devel/pyside6-tools/pkg-plist
new file mode 100644
index 000000000000..572d7a6bfb30
--- /dev/null
+++ b/devel/pyside6-tools/pkg-plist
@@ -0,0 +1,37 @@
+bin/assistant
+bin/deploy.py
+bin/deploy/__init__.py
+bin/deploy/commands.py
+bin/deploy/config.py
+bin/deploy/default.spec
+bin/deploy/nuitka_helper.py
+bin/deploy/pyside_icon.jpg
+bin/deploy/python_helper.py
+bin/designer
+bin/linguist
+bin/lrelease
+bin/lupdate
+bin/metaobjectdump.py
+bin/project.py
+bin/project/__init__.py
+bin/project/newproject.py
+bin/project/project_data.py
+bin/project/utils.py
+bin/qml.py
+bin/qmlformat
+bin/qmlimportscanner
+bin/qmllint
+bin/qmlls
+bin/qmltyperegistrar
+bin/qtpy2cpp.py
+bin/qtpy2cpp_lib/astdump.py
+bin/qtpy2cpp_lib/formatter.py
+bin/qtpy2cpp_lib/nodedump.py
+bin/qtpy2cpp_lib/qt.py
+bin/qtpy2cpp_lib/tests/baseline/basic_test.cpp
+bin/qtpy2cpp_lib/tests/baseline/basic_test.py
+bin/qtpy2cpp_lib/tests/test_qtpy2cpp.py
+bin/qtpy2cpp_lib/tokenizer.py
+bin/qtpy2cpp_lib/visitor.py
+bin/rcc
+bin/uic
diff --git a/devel/pyside6/Makefile b/devel/pyside6/Makefile
new file mode 100644
index 000000000000..29bb55c575d0
--- /dev/null
+++ b/devel/pyside6/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= pyside6
+DISTVERSION= ${QT6_VERSION}
+CATEGORIES= devel
+MASTER_SITES= QT/official_releases/QtForPython/shiboken6/PySide6-${DISTVERSION}-src
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyside-setup-opensource-src-${DISTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python Qt bindings for Qt 6
+
+LICENSE= LGPL3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers \
+ llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
+ git>0:devel/git \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
+LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader \
+ libLLVM.so:devel/llvm${LLVM_DEFAULT} \
+ libshiboken6.abi${PYTHON_MAJOR_VER}.so:devel/shiboken6@${PY_FLAVOR}
+
+USES= cmake gl python:3.5+ qt:6 tar:xz
+USE_GL= gl
+USE_LDCONFIG= yes
+USE_PYTHON= flavors
+USE_QT= 3d 5compat base declarative doc imageformats positioning \
+ quick3d quicktimeline networkauth serialport shadertools \
+ svg tools translations wayland webchannel websockets
+
+CMAKE_ARGS+= -DPYTHON_EXECUTABLE=${PYTHON_CMD}
+
+
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= PYVERSTR=.cpython-${PYTHON_SUFFIX}${PYTHON_ABIVER}
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
+
+WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION}/sources/pyside6
+
+.if ${ARCH} == amd64 || ${ARCH} == i386
+PLIST_SUB+= WEBENGINE=""
+USE_QT+= webengine
+.else
+PLIST_SUB+= WEBENGINE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pyside6/distinfo b/devel/pyside6/distinfo
new file mode 100644
index 000000000000..a0bf88724689
--- /dev/null
+++ b/devel/pyside6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685944858
+SHA256 (pyside-setup-opensource-src-6.4.2.tar.xz) = 1ec9d0936332efd229650cf10fed36cadddff7a613a2ea6e897de4d504c1b505
+SIZE (pyside-setup-opensource-src-6.4.2.tar.xz) = 8759528
diff --git a/devel/pyside6/files/patch-cmake_Macros_PySideModules.cmake b/devel/pyside6/files/patch-cmake_Macros_PySideModules.cmake
new file mode 100644
index 000000000000..a191cf62dfcd
--- /dev/null
+++ b/devel/pyside6/files/patch-cmake_Macros_PySideModules.cmake
@@ -0,0 +1,11 @@
+--- cmake/Macros/PySideModules.cmake.orig 2023-06-05 07:34:38 UTC
++++ cmake/Macros/PySideModules.cmake
+@@ -104,7 +104,7 @@ macro(create_pyside_module)
+ get_target_property(qt_core_includes Qt${QT_MAJOR_VERSION}::Core
+ INTERFACE_INCLUDE_DIRECTORIES)
+ set(shiboken_include_dir_list ${pyside6_SOURCE_DIR} ${qt_platform_includes}
+- ${qt_core_includes})
++ ${qt_core_includes} ${CMAKE_INSTALL_PREFIX}/include)
+
+ # Transform the path separators into something shiboken understands.
+ make_path(shiboken_include_dirs ${shiboken_include_dir_list})
diff --git a/devel/pyside6/pkg-descr b/devel/pyside6/pkg-descr
new file mode 100644
index 000000000000..1e9fb874bdaa
--- /dev/null
+++ b/devel/pyside6/pkg-descr
@@ -0,0 +1,5 @@
+PySide is the Python Qt bindings project, providing access to the complete
+Qt 6 framework as well as to generator tools for rapidly generating
+Python bindings for any C++ libraries.
+
+WWW: https://wiki.qt.io/Qt_for_Python
diff --git a/devel/pyside6/pkg-plist b/devel/pyside6/pkg-plist
new file mode 100644
index 000000000000..ed2259fafffa
--- /dev/null
+++ b/devel/pyside6/pkg-plist
@@ -0,0 +1,246 @@
+include/PySide6/Qt3DAnimation/pyside6_qt3danimation_python.h
+include/PySide6/Qt3DCore/pyside6_qt3dcore_python.h
+include/PySide6/Qt3DExtras/pyside6_qt3dextras_python.h
+include/PySide6/Qt3DInput/pyside6_qt3dinput_python.h
+include/PySide6/Qt3DLogic/pyside6_qt3dlogic_python.h
+include/PySide6/Qt3DRender/pyside6_qt3drender_python.h
+include/PySide6/QtConcurrent/pyside6_qtconcurrent_python.h
+include/PySide6/QtCore/pyside6_qtcore_python.h
+include/PySide6/QtCore/qtcorehelper.h
+include/PySide6/QtDBus/pyside6_qtdbus_python.h
+include/PySide6/QtDBus/qtdbushelper.h
+include/PySide6/QtDesigner/pyside6_qtdesigner_python.h
+include/PySide6/QtDesigner/qpydesignerextensions.h
+include/PySide6/QtGui/pyside6_qtgui_python.h
+include/PySide6/QtGui/qpytextobject.h
+include/PySide6/QtGui/qtguihelper.h
+include/PySide6/QtHelp/pyside6_qthelp_python.h
+include/PySide6/QtNetwork/pyside6_qtnetwork_python.h
+include/PySide6/QtNetworkAuth/pyside6_qtnetworkauth_python.h
+include/PySide6/QtOpenGL/pyside6_qtopengl_python.h
+include/PySide6/QtOpenGLWidgets/pyside6_qtopenglwidgets_python.h
+include/PySide6/QtPdf/pyside6_qtpdf_python.h
+include/PySide6/QtPdfWidgets/pyside6_qtpdfwidgets_python.h
+include/PySide6/QtPositioning/pyside6_qtpositioning_python.h
+include/PySide6/QtPrintSupport/pyside6_qtprintsupport_python.h
+include/PySide6/QtQml/pyside6_qtqml_python.h
+include/PySide6/QtQuick/pyside6_qtquick_python.h
+include/PySide6/QtQuick3D/pyside6_qtquick3d_python.h
+include/PySide6/QtQuickControls2/pyside6_qtquickcontrols2_python.h
+include/PySide6/QtQuickWidgets/pyside6_qtquickwidgets_python.h
+include/PySide6/QtSerialPort/pyside6_qtserialport_python.h
+include/PySide6/QtSql/pyside6_qtsql_python.h
+include/PySide6/QtSvg/pyside6_qtsvg_python.h
+include/PySide6/QtSvgWidgets/pyside6_qtsvgwidgets_python.h
+include/PySide6/QtTest/pyside6_qttest_python.h
+include/PySide6/QtUiTools/pyside6_qtuitools_python.h
+include/PySide6/QtWebChannel/pyside6_qtwebchannel_python.h
+include/PySide6/QtWebEngineCore/pyside6_qtwebenginecore_python.h
+include/PySide6/QtWebEngineQuick/pyside6_qtwebenginequick_python.h
+include/PySide6/QtWebEngineWidgets/pyside6_qtwebenginewidgets_python.h
+include/PySide6/QtWebSockets/pyside6_qtwebsockets_python.h
+include/PySide6/QtWidgets/pyside6_qtwidgets_python.h
+include/PySide6/QtXml/pyside6_qtxml_python.h
+include/PySide6/class_property.h
+include/PySide6/dynamicqmetaobject.h
+include/PySide6/feature_select.h
+include/PySide6/globalreceiverv2.h
+include/PySide6/pyside.h
+include/PySide6/pyside6_global.h
+include/PySide6/pyside_numpy.h
+include/PySide6/pyside_p.h
+include/PySide6/pysideclassdecorator_p.h
+include/PySide6/pysideclassinfo.h
+include/PySide6/pysideclassinfo_p.h
+include/PySide6/pysidecleanup.h
+include/PySide6/pysideinit.h
+include/PySide6/pysidelogging_p.h
+include/PySide6/pysidemacros.h
+include/PySide6/pysidemetafunction.h
+include/PySide6/pysidemetafunction_p.h
+include/PySide6/pysidemetatype.h
+include/PySide6/pysideproperty.h
+include/PySide6/pysideproperty_p.h
+include/PySide6/pysideqapp.h
+include/PySide6/pysideqenum.h
+include/PySide6/pysideqflags.h
+include/PySide6/pysideqhash.h
+include/PySide6/pysideqmetatype.h
+include/PySide6/pysideqml.h
+include/PySide6/pysideqmlattached.h
+include/PySide6/pysideqmlattached_p.h
+include/PySide6/pysideqmlextended_p.h
+include/PySide6/pysideqmlforeign_p.h
+include/PySide6/pysideqmllistproperty_p.h
+include/PySide6/pysideqmlmacros.h
+include/PySide6/pysideqmlmetacallerror_p.h
+include/PySide6/pysideqmlnamedelement_p.h
+include/PySide6/pysideqmlregistertype.h
+include/PySide6/pysideqmlregistertype_p.h
+include/PySide6/pysideqmltypeinfo_p.h
+include/PySide6/pysideqmluncreatable.h
+include/PySide6/pysideqobject.h
+include/PySide6/pysidesignal.h
+include/PySide6/pysidesignal_p.h
+include/PySide6/pysideslot_p.h
+include/PySide6/pysidestaticstrings.h
+include/PySide6/pysideutils.h
+include/PySide6/pysideweakref.h
+include/PySide6/qobjectconnect.h
+include/PySide6/signalmanager.h
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DAnimation.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DCore.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DExtras.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DInput.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DLogic.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/Qt3DRender.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtConcurrent.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtCore.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtDBus.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtDesigner.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtGui.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtHelp.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtNetwork.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtNetworkAuth.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtOpenGL.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtOpenGLWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtPdf.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtPdfWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtPositioning.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtPrintSupport.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtQml.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtQuick.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtQuick3D.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtQuickControls2.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtQuickWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtSerialPort.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtSql.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtSvg.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtSvgWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtTest.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtUiTools.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWebChannel.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWebEngineCore.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWebEngineQuick.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWebEngineWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWebSockets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtWidgets.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtXml.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/__init__.py
+%%PYTHON_SITELIBDIR%%/PySide6/_config.py
+%%PYTHON_SITELIBDIR%%/PySide6/_git_pyside_version.py
+lib/cmake/PySide6-%%DISTVERSION%%/PySide6Config.abi3.cmake
+lib/cmake/PySide6-%%DISTVERSION%%/PySide6Config.cmake
+lib/cmake/PySide6-%%DISTVERSION%%/PySide6ConfigVersion.cmake
+lib/cmake/PySide6-%%DISTVERSION%%/PySide6Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/PySide6-%%DISTVERSION%%/PySide6Targets.cmake
+lib/cmake/PySide6Qml-%%DISTVERSION%%/PySide6QmlConfig.abi3.cmake
+lib/cmake/PySide6Qml-%%DISTVERSION%%/PySide6QmlConfig.cmake
+lib/cmake/PySide6Qml-%%DISTVERSION%%/PySide6QmlConfigVersion.cmake
+lib/cmake/PySide6Qml-%%DISTVERSION%%/PySide6QmlTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/PySide6Qml-%%DISTVERSION%%/PySide6QmlTargets.cmake
+lib/libpyside6.abi3.so
+lib/libpyside6.abi3.so.%%DISTVERSION%%
+lib/libpyside6.abi3.so.6.4
+lib/libpyside6qml.abi3.so
+lib/libpyside6qml.abi3.so.%%DISTVERSION%%
+lib/libpyside6qml.abi3.so.6.4
+libdata/pkgconfig/pyside6.pc
+plugins/designer/libPySidePlugin.so
+share/PySide6/glue/qtcore.cpp
+share/PySide6/glue/qtdesigner.cpp
+share/PySide6/glue/qtgui.cpp
+share/PySide6/glue/qtnetwork.cpp
+share/PySide6/glue/qtnetworkauth.cpp
+share/PySide6/glue/qtopengl.cpp
+share/PySide6/glue/qtprintsupport.cpp
+share/PySide6/glue/qtqml.cpp
+share/PySide6/glue/qtquick.cpp
+share/PySide6/glue/qtsql.cpp
+share/PySide6/glue/qttest.cpp
+share/PySide6/glue/qtuitools.cpp
+share/PySide6/glue/qtwebenginecore.cpp
+share/PySide6/glue/qtwebenginewidgets.cpp
+share/PySide6/glue/qtwidgets.cpp
+share/PySide6/glue/qtxml.cpp
+share/PySide6/typesystems/common.xml
+share/PySide6/typesystems/core_common.xml
+share/PySide6/typesystems/datavisualization_common.xml
+share/PySide6/typesystems/glue/plugins.h
+share/PySide6/typesystems/glue/qeasingcurve_glue.cpp
+share/PySide6/typesystems/glue/qeasingcurve_glue.h
+share/PySide6/typesystems/gui_common.xml
+share/PySide6/typesystems/opengl_common.xml
+share/PySide6/typesystems/typesystem_3danimation.xml
+share/PySide6/typesystems/typesystem_3dcore.xml
+share/PySide6/typesystems/typesystem_3dextras.xml
+share/PySide6/typesystems/typesystem_3dinput.xml
+share/PySide6/typesystems/typesystem_3dlogic.xml
+share/PySide6/typesystems/typesystem_3drender.xml
+share/PySide6/typesystems/typesystem_concurrent.xml
+share/PySide6/typesystems/typesystem_core.xml
+share/PySide6/typesystems/typesystem_core_common.xml
+share/PySide6/typesystems/typesystem_core_win.xml
+share/PySide6/typesystems/typesystem_dbus.xml
+share/PySide6/typesystems/typesystem_designer.xml
+share/PySide6/typesystems/typesystem_glgeti_v_includes.xml
+share/PySide6/typesystems/typesystem_glgeti_v_modifications.xml
+share/PySide6/typesystems/typesystem_glgetv_includes.xml
+share/PySide6/typesystems/typesystem_glgetv_modifications.xml
+share/PySide6/typesystems/typesystem_gui.xml
+share/PySide6/typesystems/typesystem_gui_common.xml
+share/PySide6/typesystems/typesystem_gui_mac.xml
+share/PySide6/typesystems/typesystem_gui_win.xml
+share/PySide6/typesystems/typesystem_gui_x11.xml
+share/PySide6/typesystems/typesystem_help.xml
+share/PySide6/typesystems/typesystem_network.xml
+share/PySide6/typesystems/typesystem_networkauth.xml
+share/PySide6/typesystems/typesystem_opengl.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_0.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_0_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_1.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_1_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_2_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_3_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_4.xml
+share/PySide6/typesystems/typesystem_opengl_modifications1_4_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications2_0.xml
+share/PySide6/typesystems/typesystem_opengl_modifications2_0_compat.xml
+share/PySide6/typesystems/typesystem_opengl_modifications2_1.xml
+share/PySide6/typesystems/typesystem_opengl_modifications3_0.xml
+share/PySide6/typesystems/typesystem_opengl_modifications3_3.xml
+share/PySide6/typesystems/typesystem_opengl_modifications3_3a.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_0.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_1.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_3.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_4.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_4_core.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_5.xml
+share/PySide6/typesystems/typesystem_opengl_modifications4_5_core.xml
+share/PySide6/typesystems/typesystem_opengl_modifications_va.xml
+share/PySide6/typesystems/typesystem_openglwidgets.xml
+share/PySide6/typesystems/typesystem_pdf.xml
+share/PySide6/typesystems/typesystem_pdfwidgets.xml
+share/PySide6/typesystems/typesystem_positioning.xml
+share/PySide6/typesystems/typesystem_printsupport.xml
+share/PySide6/typesystems/typesystem_printsupport_common.xml
+share/PySide6/typesystems/typesystem_qml.xml
+share/PySide6/typesystems/typesystem_quick.xml
+share/PySide6/typesystems/typesystem_quick3d.xml
+share/PySide6/typesystems/typesystem_quickcontrols2.xml
+share/PySide6/typesystems/typesystem_quickwidgets.xml
+share/PySide6/typesystems/typesystem_serialport.xml
+share/PySide6/typesystems/typesystem_sql.xml
+share/PySide6/typesystems/typesystem_svg.xml
+share/PySide6/typesystems/typesystem_svgwidgets.xml
+share/PySide6/typesystems/typesystem_test.xml
+share/PySide6/typesystems/typesystem_uitools.xml
+share/PySide6/typesystems/typesystem_webchannel.xml
+share/PySide6/typesystems/typesystem_webenginecore.xml
+share/PySide6/typesystems/typesystem_webenginequick.xml
+share/PySide6/typesystems/typesystem_webenginewidgets.xml
+share/PySide6/typesystems/typesystem_websockets.xml
+share/PySide6/typesystems/typesystem_widgets.xml
+share/PySide6/typesystems/typesystem_widgets_common.xml
+share/PySide6/typesystems/typesystem_xml.xml
+share/PySide6/typesystems/widgets_common.xml
diff --git a/devel/shiboken6/Makefile b/devel/shiboken6/Makefile
new file mode 100644
index 000000000000..1ac6f98010e1
--- /dev/null
+++ b/devel/shiboken6/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= shiboken6
+DISTVERSION= ${QT6_VERSION}
+CATEGORIES= devel
+MASTER_SITES= QT/official_releases/QtForPython/${PORTNAME}/PySide6-${DISTVERSION}-src
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyside-setup-opensource-src-${DISTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python binding generator for C++ libraries
+
+LICENSE= GPLv2 LGPL21 LGPL3
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers \
+ llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
+ git>0:devel/git \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
+LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader \
+ libLLVM.so:devel/llvm${LLVM_DEFAULT} \
+ libxslt.so:textproc/libxslt
+
+USES= cmake compiler:c++17-lang gnome localbase python:3.5+ \
+ shebangfix tar:xz qt:6
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+USE_PYTHON= flavors
+USE_QT= 5compat base declarative doc imageformats quick3d quicktimeline networkauth shadertools svg tools translations wayland
+
+# TODO: avoid a conflict with shiboken2
+SHEBANG_FILES= shiboken_tool.py
+
+CMAKE_ARGS+= -DClang_DIR:PATH="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/cmake/clang" \
+ -DLLVM_DIR:PATH="${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/cmake/llvm" \
+ -DCMAKE_CXX_FLAGS=-lexecinfo \
+ -DCMAKE_STANDARD_LIBRARIES=-lexecinfo \
+ -DCMAKE_CXX_STANDARD_LIBRARIES=-lexecinfo \
+ -DUSE_PYTHON_VERSION=${PYTHON_VER}
+
+
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
+PLIST_SUB+= PYVERSTR=.cpython-${PYTHON_SUFFIX}${PYTHON_ABIVER}
+WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION}/sources/shiboken6
+
+.include <bsd.port.post.mk>
diff --git a/devel/shiboken6/distinfo b/devel/shiboken6/distinfo
new file mode 100644
index 000000000000..14c8e5bf2401
--- /dev/null
+++ b/devel/shiboken6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685944850
+SHA256 (pyside-setup-opensource-src-6.4.2.tar.xz) = 1ec9d0936332efd229650cf10fed36cadddff7a613a2ea6e897de4d504c1b505
+SIZE (pyside-setup-opensource-src-6.4.2.tar.xz) = 8759528
diff --git a/devel/shiboken6/files/patch-data_shiboken6.pc.in b/devel/shiboken6/files/patch-data_shiboken6.pc.in
new file mode 100644
index 000000000000..3496cfee10da
--- /dev/null
+++ b/devel/shiboken6/files/patch-data_shiboken6.pc.in
@@ -0,0 +1,9 @@
+--- data/shiboken6.pc.in.orig 2020-12-13 08:07:53 UTC
++++ data/shiboken6.pc.in
+@@ -9,5 +9,5 @@ python_include_dir=@PYTHON_INCLUDE_DIRS@
+ Name: shiboken6
+ Description: Support library for Python bindings created with the Shiboken6 generator.
+ Version: @shiboken6_VERSION@
+-Libs: @SHIBOKEN_PYTHON_LIBRARIES@ -L${libdir} -lshiboken6@shiboken6_SUFFIX@@PYTHON_SHARED_LIBRARY_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
++Libs: @SHIBOKEN_PYTHON_LIBRARIES@ -L${libdir} -lshiboken6@shiboken6_SUFFIX@@PYTHON_SHARED_LIBRARY_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@ -lexecinfo
+ Cflags: -I@PYTHON_INCLUDE_DIRS@ -I${includedir}/@shiboken6_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
diff --git a/devel/shiboken6/files/patch-doc_CMakeLists.txt b/devel/shiboken6/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..55bf1b5312c3
--- /dev/null
+++ b/devel/shiboken6/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,9 @@
+--- doc/CMakeLists.txt.orig 2020-12-13 08:06:40 UTC
++++ doc/CMakeLists.txt
+@@ -58,5 +58,5 @@ endif()
+
+ if (NOT WIN32)
+ file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/*.1")
+- install(FILES ${manpages} DESTINATION share/man/man1)
++ install(FILES ${manpages} DESTINATION man/man1)
+ endif()
diff --git a/devel/shiboken6/files/patch-sources_shiboken6_libshiboken_helper.h b/devel/shiboken6/files/patch-sources_shiboken6_libshiboken_helper.h
new file mode 100644
index 000000000000..d7333d860c45
--- /dev/null
+++ b/devel/shiboken6/files/patch-sources_shiboken6_libshiboken_helper.h
@@ -0,0 +1,11 @@
+--- libshiboken/helper.h.orig 2020-12-13 07:16:46 UTC
++++ libshiboken/helper.h
+@@ -92,7 +92,7 @@ class AutoArrayPointer
+ T *data;
+ };
+
+-using ThreadId = unsigned long long;
++using ThreadId = pthread_t;
+ LIBSHIBOKEN_API ThreadId currentThreadId();
+ LIBSHIBOKEN_API ThreadId mainThreadId();
+
diff --git a/devel/shiboken6/pkg-descr b/devel/shiboken6/pkg-descr
new file mode 100644
index 000000000000..06bb1d9109d5
--- /dev/null
+++ b/devel/shiboken6/pkg-descr
@@ -0,0 +1,7 @@
+Qt is a cross-platform application and UI framework for developers
+using C++ or QML, a CSS/JavaScript-like language.
+
+Qt Quick is a collection of technologies that are designed to help
+developers create intuitive, modern, and fluid user interfaces.
+
+WWW: http://qt-project.org
diff --git a/devel/shiboken6/pkg-plist b/devel/shiboken6/pkg-plist
new file mode 100644
index 000000000000..25003ef03c6d
--- /dev/null
+++ b/devel/shiboken6/pkg-plist
@@ -0,0 +1,57 @@
+bin/shiboken6
+bin/shiboken_tool.py
+include/shiboken6/autodecref.h
+include/shiboken6/basewrapper.h
+include/shiboken6/basewrapper_p.h
+include/shiboken6/bindingmanager.h
+include/shiboken6/bufferprocs_py37.h
+include/shiboken6/gilstate.h
+include/shiboken6/helper.h
+include/shiboken6/pep384impl.h
+include/shiboken6/sbkarrayconverter.h
+include/shiboken6/sbkcontainer.h
+include/shiboken6/sbkconverter.h
+include/shiboken6/sbkcppstring.h
+include/shiboken6/sbkcpptonumpy.h
+include/shiboken6/sbkenum.h
+include/shiboken6/sbkenum_p.h
+include/shiboken6/sbkerrors.h
+include/shiboken6/sbkfeature_base.h
+include/shiboken6/sbkmodule.h
+include/shiboken6/sbknumpycheck.h
+include/shiboken6/sbknumpyview.h
+include/shiboken6/sbkpython.h
+include/shiboken6/sbkstaticstrings.h
+include/shiboken6/sbkstring.h
+include/shiboken6/sbktypefactory.h
+include/shiboken6/sbkversion.h
+include/shiboken6/shiboken.h
+include/shiboken6/shibokenbuffer.h
+include/shiboken6/shibokenmacros.h
+include/shiboken6/signature.h
+include/shiboken6/signature_p.h
+include/shiboken6/threadstatesaver.h
+include/shiboken6/voidptr.h
+lib/cmake/Shiboken6-%%DISTVERSION%%/Shiboken6Config.abi3.cmake
+lib/cmake/Shiboken6-%%DISTVERSION%%/Shiboken6Config.cmake
+lib/cmake/Shiboken6-%%DISTVERSION%%/Shiboken6ConfigVersion.cmake
+lib/cmake/Shiboken6-%%DISTVERSION%%/Shiboken6Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Shiboken6-%%DISTVERSION%%/Shiboken6Targets.cmake
+lib/cmake/Shiboken6-%%DISTVERSION%%/ShibokenHelpers.cmake
+lib/cmake/Shiboken6Tools/Shiboken6ToolsConfig.cmake
+lib/cmake/Shiboken6Tools/Shiboken6ToolsConfigVersion.cmake
+lib/cmake/Shiboken6Tools/Shiboken6ToolsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Shiboken6Tools/Shiboken6ToolsTargets.cmake
+lib/libshiboken6.abi3.so
+lib/libshiboken6.abi3.so.6.4
+lib/libshiboken6.abi3.so.%%DISTVERSION%%
+%%PYTHON_SITELIBDIR%%/shiboken6/Shiboken.abi3.so
+%%PYTHON_SITELIBDIR%%/shiboken6/Shiboken.pyi
+%%PYTHON_SITELIBDIR%%/shiboken6/__init__.py
+%%PYTHON_SITELIBDIR%%/shiboken6/_config.py
+%%PYTHON_SITELIBDIR%%/shiboken6/_git_shiboken_module_version.py
+%%PYTHON_SITELIBDIR%%/shiboken6/py.typed
+%%PYTHON_SITELIBDIR%%/shiboken6_generator/__init__.py
+%%PYTHON_SITELIBDIR%%/shiboken6_generator/_config.py
+%%PYTHON_SITELIBDIR%%/shiboken6_generator/_git_shiboken_generator_version.py
+libdata/pkgconfig/shiboken6.pc