aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:50 +0000
commitd5fbf3e3709df603485e3c580fe4b7a58a2f811a (patch)
tree6efaeeeb5ab25adebdd90eee8a631dc482e085c5
parentd9c5f06601639502ec470612afa89678ac46013b (diff)
downloadports-d5fbf3e3709df603485e3c580fe4b7a58a2f811a.tar.gz
ports-d5fbf3e3709df603485e3c580fe4b7a58a2f811a.zip
devel/py-click-option-group: Add py-click-option-group 0.5.5
click-option-group is a Click-extension package that adds option groups missing in Click. Click is a package for creating powerful and beautiful command line interfaces (CLI) in Python, but it has no the functionality for creating option groups. Option groups are convenient mechanism for logical structuring CLI, also it allows you to set the specific behavior and set the relationship among grouped options (mutually exclusive options for example). Moreover, argparse stdlib package contains this functionality out of the box. At the same time, many Click users need this functionality. You can read interesting discussions about it in the issues 257, 373, 509 and 1137. The aim of this package is to provide group options with extensible functionality using canonical and clean API (Click-like API as far as possible).
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-click-option-group/Makefile21
-rw-r--r--devel/py-click-option-group/distinfo3
-rw-r--r--devel/py-click-option-group/pkg-descr16
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f8b981626d9..3710ea03e521 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4412,6 +4412,7 @@
SUBDIR += py-click-default-group
SUBDIR += py-click-default-group-wheel
SUBDIR += py-click-log
+ SUBDIR += py-click-option-group
SUBDIR += py-click-plugins
SUBDIR += py-click-threading
SUBDIR += py-click7
diff --git a/devel/py-click-option-group/Makefile b/devel/py-click-option-group/Makefile
new file mode 100644
index 000000000000..a242e5573867
--- /dev/null
+++ b/devel/py-click-option-group/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= click-option-group
+PORTVERSION= 0.5.5
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Option groups missing in Click
+WWW= https://github.com/click-contrib/click-option-group
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=7.0<9:devel/py-click@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-click-option-group/distinfo b/devel/py-click-option-group/distinfo
new file mode 100644
index 000000000000..a71308d2a7ce
--- /dev/null
+++ b/devel/py-click-option-group/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677770919
+SHA256 (click-option-group-0.5.5.tar.gz) = 78ee474f07a0ca0ef6c0317bb3ebe79387aafb0c4a1e03b1d8b2b0be1e42fc78
+SIZE (click-option-group-0.5.5.tar.gz) = 15961
diff --git a/devel/py-click-option-group/pkg-descr b/devel/py-click-option-group/pkg-descr
new file mode 100644
index 000000000000..f6e1a185a2a5
--- /dev/null
+++ b/devel/py-click-option-group/pkg-descr
@@ -0,0 +1,16 @@
+click-option-group is a Click-extension package that adds option groups missing
+in Click.
+
+Click is a package for creating powerful and beautiful command line interfaces
+(CLI) in Python, but it has no the functionality for creating option groups.
+
+Option groups are convenient mechanism for logical structuring CLI, also it
+allows you to set the specific behavior and set the relationship among grouped
+options (mutually exclusive options for example). Moreover, argparse stdlib
+package contains this functionality out of the box.
+
+At the same time, many Click users need this functionality. You can read
+interesting discussions about it in the issues 257, 373, 509 and 1137.
+
+The aim of this package is to provide group options with extensible
+functionality using canonical and clean API (Click-like API as far as possible).