aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Jensen <erik@tenku.dk>2024-01-20 12:49:21 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-01-20 12:50:52 +0000
commitd6ffd622a326012a592c6c5d1b8f413a9c245735 (patch)
tree7ba20b15b7328df6ee58ddfd51317e54a7aeb47f
parent95a1d58657288cd82883f881848a004d213e64a5 (diff)
downloadports-d6ffd622a326012a592c6c5d1b8f413a9c245735.tar.gz
ports-d6ffd622a326012a592c6c5d1b8f413a9c245735.zip
devel/root: Re-enable MathMore for release 6.30/02 and fix debug build
I overlooked a dependency change in the source code of the latest release and, as a result, the MathMore option was mistakenly auto-disabled at the configure stage in the latest port revision. I also noticed a failure to build with debug symbols enabled. PR: 276373
-rw-r--r--devel/root/Makefile4
-rw-r--r--devel/root/files/patch-interpreter_llvm-project_clang_lib_Serialization_ASTWriter.cpp13
-rw-r--r--devel/root/pkg-plist57
3 files changed, 73 insertions, 1 deletions
diff --git a/devel/root/Makefile b/devel/root/Makefile
index 5e2e1dff02c7..fb7f875369d5 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -1,5 +1,6 @@
PORTNAME= root
DISTVERSION= 6.30.02
+PORTREVISION= 1
CATEGORIES= devel science math parallel python
MASTER_SITES= https://root.cern/download/
DISTFILES= ${PORTNAME}_v${DISTVERSION}.source${EXTRACT_SUFX}
@@ -17,6 +18,7 @@ BUILD_DEPENDS= ${BUILD_AND_RUN_DEPENDS}
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libcurl.so:ftp/curl \
libfreetype.so:print/freetype2 \
+ libgsl.so:math/gsl \
liblz4.so:archivers/liblz4 \
libopenblas.so:math/openblas \
libpcre.so:devel/pcre \
@@ -38,7 +40,7 @@ SHEBANG_FILES= config/rootssh etc/dictpch/makepch.py etc/proof/utils/circle.sh \
# Flags and environment variables for building
CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17
-CMAKE_ON= gnuinstall soversion
+CMAKE_ON= gnuinstall soversion mathmore
CMAKE_OFF= builtin_gtest clad
CONFIGURE_WRKSRC?= ${WRKDIR}/.build
MAKE_ENV+= ROOTSYS=${CONFIGURE_WRKSRC}
diff --git a/devel/root/files/patch-interpreter_llvm-project_clang_lib_Serialization_ASTWriter.cpp b/devel/root/files/patch-interpreter_llvm-project_clang_lib_Serialization_ASTWriter.cpp
new file mode 100644
index 000000000000..556a68a289ab
--- /dev/null
+++ b/devel/root/files/patch-interpreter_llvm-project_clang_lib_Serialization_ASTWriter.cpp
@@ -0,0 +1,13 @@
+--- interpreter/llvm-project/clang/lib/Serialization/ASTWriter.cpp.orig 2024-01-11 19:51:52 UTC
++++ interpreter/llvm-project/clang/lib/Serialization/ASTWriter.cpp
+@@ -2498,8 +2498,10 @@ unsigned ASTWriter::getSubmoduleID(Module *Mod) {
+ // did not result in us loading a module file for that submodule. For
+ // instance, a cross-top-level-module 'conflict' declaration will hit this.
+ unsigned ID = getLocalOrImportedSubmoduleID(Mod);
++ /*
+ assert((ID || !Mod) &&
+ "asked for module ID for non-local, non-imported module");
++ */
+ return ID;
+ }
+
diff --git a/devel/root/pkg-plist b/devel/root/pkg-plist
index 80dbc89d24ba..856f58b5a8fd 100644
--- a/devel/root/pkg-plist
+++ b/devel/root/pkg-plist
@@ -628,6 +628,7 @@ include/root/Math/BrentMinimizer1D.h
include/root/Math/BrentRootFinder.h
include/root/Math/Cartesian2D.h
include/root/Math/Cartesian3D.h
+include/root/Math/ChebyshevApprox.h
include/root/Math/ChebyshevPol.h
include/root/Math/CholeskyDecomp.h
include/root/Math/CladDerivator.h
@@ -636,6 +637,7 @@ include/root/Math/CramerInversionSym.icc
include/root/Math/Cylindrical3D.h
include/root/Math/CylindricalEta3D.h
include/root/Math/Delaunay2D.h
+include/root/Math/Derivator.h
include/root/Math/Dfact.h
include/root/Math/Dfactir.h
include/root/Math/Dfinv.h
@@ -644,6 +646,7 @@ include/root/Math/DisplacementVector2D.h
include/root/Math/DisplacementVector3D.h
include/root/Math/DistFunc.h
include/root/Math/DistFuncMathCore.h
+include/root/Math/DistFuncMathMore.h
include/root/Math/DistSampler.h
include/root/Math/DistSamplerOptions.h
include/root/Math/Dsfact.h
@@ -655,6 +658,22 @@ include/root/Math/Factory.h
include/root/Math/FitMethodFunction.h
include/root/Math/Functions.h
include/root/Math/Functor.h
+include/root/Math/GSLFunctionAdapter.h
+include/root/Math/GSLIntegrator.h
+include/root/Math/GSLMCIntegrator.h
+include/root/Math/GSLMinimizer.h
+include/root/Math/GSLMinimizer1D.h
+include/root/Math/GSLMultiRootFinder.h
+include/root/Math/GSLNLSMinimizer.h
+include/root/Math/GSLQuasiRandom.h
+include/root/Math/GSLRandom.h
+include/root/Math/GSLRandomFunctions.h
+include/root/Math/GSLRndmEngines.h
+include/root/Math/GSLRootFinder.h
+include/root/Math/GSLRootFinderDeriv.h
+include/root/Math/GSLRootHelper.h
+include/root/Math/GSLSimAnMinimizer.h
+include/root/Math/GSLSimAnnealing.h
include/root/Math/GaussIntegrator.h
include/root/Math/GaussLegendreIntegrator.h
include/root/Math/GenAlgoOptions.h
@@ -736,14 +755,19 @@ include/root/Math/IOptions.h
include/root/Math/IParamFunction.h
include/root/Math/IParamFunctionfwd.h
include/root/Math/IRootFinderMethod.h
+include/root/Math/IntegrationTypes.h
include/root/Math/Integrator.h
include/root/Math/IntegratorMultiDim.h
include/root/Math/IntegratorOptions.h
+include/root/Math/InterpolationTypes.h
+include/root/Math/Interpolator.h
include/root/Math/KDTree.h
include/root/Math/KDTree.icc
include/root/Math/LCGEngine.h
include/root/Math/LorentzRotation.h
include/root/Math/LorentzVector.h
+include/root/Math/MCIntegrationTypes.h
+include/root/Math/MCParameters.h
include/root/Math/MConfig.h
include/root/Math/Math.h
include/root/Math/MatrixFunctions.h
@@ -758,10 +782,14 @@ include/root/Math/MinimizerVariableTransformation.h
include/root/Math/MixMaxEngine.h
include/root/Math/MixMaxEngine.icc
include/root/Math/MultiDimParamFunctionAdapter.h
+include/root/Math/MultiNumGradFunction.h
+include/root/Math/MultiRootFinder.h
include/root/Math/OneDimFunctionAdapter.h
+include/root/Math/ParamFunction.h
include/root/Math/ParamFunctor.h
include/root/Math/PdfFunc.h
include/root/Math/PdfFuncMathCore.h
+include/root/Math/PdfFuncMathMore.h
include/root/Math/Plane3D.h
include/root/Math/Point2D.h
include/root/Math/Point2Dfwd.h
@@ -769,6 +797,7 @@ include/root/Math/Point3D.h
include/root/Math/Point3Dfwd.h
include/root/Math/Polar2D.h
include/root/Math/Polar3D.h
+include/root/Math/Polynomial.h
include/root/Math/PositionVector2D.h
include/root/Math/PositionVector3D.h
include/root/Math/ProbFunc.h
@@ -779,12 +808,15 @@ include/root/Math/PxPyPzE4D.h
include/root/Math/PxPyPzM4D.h
include/root/Math/QuantFunc.h
include/root/Math/QuantFuncMathCore.h
+include/root/Math/QuantFuncMathMore.h
+include/root/Math/QuasiRandom.h
include/root/Math/Quaternion.h
include/root/Math/Random.h
include/root/Math/RandomFunctions.h
include/root/Math/RanluxppEngine.h
include/root/Math/RichardsonDerivator.h
include/root/Math/RootFinder.h
+include/root/Math/RootFinderAlgorithms.h
include/root/Math/Rotation3D.h
include/root/Math/RotationX.h
include/root/Math/RotationY.h
@@ -798,6 +830,7 @@ include/root/Math/SVector.h
include/root/Math/SVector.icc
include/root/Math/SpecFunc.h
include/root/Math/SpecFuncMathCore.h
+include/root/Math/SpecFuncMathMore.h
include/root/Math/StaticCheck.h
include/root/Math/StdEngine.h
include/root/Math/TDataPoint.h
@@ -810,6 +843,12 @@ include/root/Math/Translation3D.h
include/root/Math/Types.h
include/root/Math/UnaryOperators.h
include/root/Math/Util.h
+include/root/Math/Vavilov.h
+include/root/Math/VavilovAccurate.h
+include/root/Math/VavilovAccurateCdf.h
+include/root/Math/VavilovAccuratePdf.h
+include/root/Math/VavilovAccurateQuantile.h
+include/root/Math/VavilovFast.h
include/root/Math/Vector2D.h
include/root/Math/Vector2Dfwd.h
include/root/Math/Vector3D.h
@@ -1265,6 +1304,7 @@ include/root/RooAbsSelfCachedPdf.h
include/root/RooAbsSelfCachedReal.h
include/root/RooAbsStudy.h
include/root/RooAbsTestStatistic.h
+include/root/RooAdaptiveGaussKronrodIntegrator1D.h
include/root/RooAdaptiveIntegratorND.h
include/root/RooAddGenContext.h
include/root/RooAddModel.h
@@ -1376,6 +1416,7 @@ include/root/RooFitHS3/RooJSONFactoryWSTool.h
include/root/RooFitLegacy/RooCatTypeLegacy.h
include/root/RooFitLegacy/RooCategorySharedProperties.h
include/root/RooFitLegacy/RooTreeData.h
+include/root/RooFitMoreLib.h
include/root/RooFitResult.h
include/root/RooFormulaVar.h
include/root/RooFracRemainder.h
@@ -1385,6 +1426,7 @@ include/root/RooFunctor1DBinding.h
include/root/RooFunctorBinding.h
include/root/RooGExpModel.h
include/root/RooGamma.h
+include/root/RooGaussKronrodIntegrator1D.h
include/root/RooGaussModel.h
include/root/RooGaussian.h
include/root/RooGenContext.h
@@ -1398,6 +1440,7 @@ include/root/RooHistConstraint.h
include/root/RooHistError.h
include/root/RooHistFunc.h
include/root/RooHistPdf.h
+include/root/RooHypatia2.h
include/root/RooImproperIntegrator1D.h
include/root/RooIntegralMorph.h
include/root/RooInvTransform.h
@@ -1406,6 +1449,7 @@ include/root/RooJohnson.h
include/root/RooKeysPdf.h
include/root/RooLagrangianMorphFunc.h
include/root/RooLandau.h
+include/root/RooLegendre.h
include/root/RooLinTransBinning.h
include/root/RooLinearCombination.h
include/root/RooLinearVar.h
@@ -1419,6 +1463,7 @@ include/root/RooMCStudy.h
include/root/RooMappedCategory.h
include/root/RooMath.h
include/root/RooMathCoreReg.h
+include/root/RooMathMoreReg.h
include/root/RooMinimizer.h
include/root/RooMoment.h
include/root/RooMomentMorph.h
@@ -1432,6 +1477,7 @@ include/root/RooNDKeysPdf.h
include/root/RooNLLVar.h
include/root/RooNameReg.h
include/root/RooNonCPEigenDecay.h
+include/root/RooNonCentralChiSquare.h
include/root/RooNormSetCache.h
include/root/RooNovosibirsk.h
include/root/RooNumCdf.h
@@ -1488,6 +1534,7 @@ include/root/RooSimGenContext.h
include/root/RooSimSplitGenContext.h
include/root/RooSimWSTool.h
include/root/RooSimultaneous.h
+include/root/RooSpHarmonic.h
include/root/RooSpline.h
include/root/RooStats/AsymptoticCalculator.h
include/root/RooStats/BayesianCalculator.h
@@ -3269,6 +3316,7 @@ lib/root/%%AARCH64_PCM_PREFIX%%Html%%AARCH64_PCM_SUFFIX%%.pcm
%%PYROOT%%lib/root/JupyROOT/magics/jsrootmagic.py
lib/root/%%AARCH64_PCM_PREFIX%%MLP%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%MathCore%%AARCH64_PCM_SUFFIX%%.pcm
+lib/root/%%AARCH64_PCM_PREFIX%%MathMore%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%Matrix%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%Minuit%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%Minuit2%%AARCH64_PCM_SUFFIX%%.pcm
@@ -3538,6 +3586,7 @@ lib/root/%%AARCH64_PCM_PREFIX%%RooFit%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%RooFitCore%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%RooFitHS3%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%RooFitJSONInterface%%AARCH64_PCM_SUFFIX%%.pcm
+lib/root/%%AARCH64_PCM_PREFIX%%RooFitMore%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%RooFitRDataFrameHelpers%%AARCH64_PCM_SUFFIX%%.pcm
%%ROOT7%%lib/root/%%AARCH64_PCM_PREFIX%%RooFitXRooFit%%AARCH64_PCM_SUFFIX%%.pcm
lib/root/%%AARCH64_PCM_PREFIX%%RooStats%%AARCH64_PCM_SUFFIX%%.pcm
@@ -3758,6 +3807,10 @@ lib/root/libMLP.so.%%SHLIB_VER%%
lib/root/libMathCore.so
lib/root/libMathCore.so.%%SHLIB_SHVER%%
lib/root/libMathCore.so.%%SHLIB_VER%%
+%%ONLY_INSTALLED_ON_AARCH64%%lib/root/libMathMore.rootmap
+lib/root/libMathMore.so
+lib/root/libMathMore.so.%%SHLIB_SHVER%%
+lib/root/libMathMore.so.%%SHLIB_VER%%
%%ONLY_INSTALLED_ON_AARCH64%%lib/root/libMatrix.rootmap
lib/root/libMatrix.so
lib/root/libMatrix.so.%%SHLIB_SHVER%%
@@ -3999,6 +4052,10 @@ lib/root/libRooFitHS3.so.%%SHLIB_VER%%
lib/root/libRooFitJSONInterface.so
lib/root/libRooFitJSONInterface.so.%%SHLIB_SHVER%%
lib/root/libRooFitJSONInterface.so.%%SHLIB_VER%%
+%%ONLY_INSTALLED_ON_AARCH64%%lib/root/libRooFitMore.rootmap
+lib/root/libRooFitMore.so
+lib/root/libRooFitMore.so.%%SHLIB_SHVER%%
+lib/root/libRooFitMore.so.%%SHLIB_VER%%
%%ONLY_INSTALLED_ON_AARCH64%%lib/root/libRooFitRDataFrameHelpers.rootmap
lib/root/libRooFitRDataFrameHelpers.so
lib/root/libRooFitRDataFrameHelpers.so.%%SHLIB_SHVER%%