aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-20 21:44:40 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-20 21:53:52 +0000
commitd780766fef98ca7b1fb21ea53357b0aefb433207 (patch)
tree2bfd9b7f4608dca1a764b529d98f7cbb522ca349
parent20e8b42e2b7388c97514575ee7ccc9f3026f481b (diff)
downloadports-d780766fef98ca7b1fb21ea53357b0aefb433207.tar.gz
ports-d780766fef98ca7b1fb21ea53357b0aefb433207.zip
graphics/openjpeg: Convert post-patch to EXTRACT_AFTER_ARGS
Instead of extracted files to later discard them just skip extracting PR: 278777 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--graphics/openjpeg/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 00f8e12f97fc..d811361b5321 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -18,6 +18,15 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
USES= cmake cpe localbase:ldflags jpeg pathfix pkgconfig
+# Clean up bundled libraries
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/astyle \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/include \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/liblcms2 \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libpng \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libtiff \
+ --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/thirdparty/libz \
+ --no-same-owner --no-same-permissions
+
CMAKE_OFF= BUILD_DOC \
BUILD_JAVA \
BUILD_JPIP \
@@ -40,13 +49,4 @@ USE_GITHUB= yes
CPE_VENDOR= uclouvain
-post-patch:
-# Clean up bundled libraries
- @${RM} -r ${WRKSRC}/thirdparty/astyle/
- @${RM} -r ${WRKSRC}/thirdparty/include/
- @${RM} -r ${WRKSRC}/thirdparty/liblcms2/
- @${RM} -r ${WRKSRC}/thirdparty/libpng/
- @${RM} -r ${WRKSRC}/thirdparty/libtiff/
- @${RM} -r ${WRKSRC}/thirdparty/libz/
-
.include <bsd.port.mk>