aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-01 20:54:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-01 23:43:16 +0000
commitd7bbc137e504473eb4d987b3069611d889f6ead6 (patch)
tree5f0878b45c7140d18c368d41e520db13604944e2
parent57185ef9a619e47eb830fa950917bd60f7f3f922 (diff)
downloadports-d7bbc137e504473eb4d987b3069611d889f6ead6.tar.gz
ports-d7bbc137e504473eb4d987b3069611d889f6ead6.zip
finance/py-pythclient: New port: Library to retrieve Pyth account structures off the Solana blockchain
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-pythclient/Makefile34
-rw-r--r--finance/py-pythclient/distinfo3
-rw-r--r--finance/py-pythclient/pkg-descr2
4 files changed, 40 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 98d6a737f20f..142edc5d88fd 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -121,6 +121,7 @@
SUBDIR += py-pandas-ta
SUBDIR += py-pycoin
SUBDIR += py-pycoingecko
+ SUBDIR += py-pythclient
SUBDIR += py-python-binance
SUBDIR += py-python-bitcoinlib
SUBDIR += py-python-coinmarketcap
diff --git a/finance/py-pythclient/Makefile b/finance/py-pythclient/Makefile
new file mode 100644
index 000000000000..19411eead01f
--- /dev/null
+++ b/finance/py-pythclient/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= pythclient
+DISTVERSION= 0.1.19
+CATEGORIES= finance python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library to retrieve Pyth account structures off the Solana blockchain
+WWW= https://github.com/pyth-network/pyth-client-py
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiodns>=0:dns/py-aiodns@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.7.4:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}backoff>=0:devel/py-backoff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}base58>=0:security/py-base58@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}loguru>=0:devel/py-loguru@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # 2 tests fail, see https://github.com/pyth-network/pyth-client-py/issues/49
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-pythclient/distinfo b/finance/py-pythclient/distinfo
new file mode 100644
index 000000000000..84b8ff951608
--- /dev/null
+++ b/finance/py-pythclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1704141918
+SHA256 (pythclient-0.1.19.tar.gz) = 06195a477522c475362407ce5c1ab1b6711efbeee79999ce39d43f047a3e2ed7
+SIZE (pythclient-0.1.19.tar.gz) = 54123
diff --git a/finance/py-pythclient/pkg-descr b/finance/py-pythclient/pkg-descr
new file mode 100644
index 000000000000..dd6a5254140a
--- /dev/null
+++ b/finance/py-pythclient/pkg-descr
@@ -0,0 +1,2 @@
+pythclient is a Python library to retrieve data from Pyth account structures
+off the Solana blockchain.