aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-16 13:16:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-16 13:50:04 +0000
commitd7c018f5c4a13e3eb01b554691b37898d33e8cfb (patch)
tree3fb99d25139e31634e19ae20fec47d85d5bace42
parent736be15f47c5f9ccc1b858d4263e150773acf29d (diff)
downloadports-d7c018f5c4a13e3eb01b554691b37898d33e8cfb.tar.gz
ports-d7c018f5c4a13e3eb01b554691b37898d33e8cfb.zip
devel/shiboken2: limit supported python versions
With python 3.10: pyside-setup-opensource-src-5.15.2/sources/shiboken2/libshiboken/pep384impl.cpp:755:12: error: use of undeclared identifier '_Py_Mangle' return _Py_Mangle(privateobj, name); ^ pyside-setup-opensource-src-5.15.2/sources/shiboken2/libshiboken/sbkstring.cpp:250:23: error: expression is not assignable Py_REFCNT(ob) = 1; ~~~~~~~~~~~~~ ^ Also mark BROKEN with python < 3.8 due to plist issues Approved by: portmgr blanket
-rw-r--r--devel/shiboken2/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/shiboken2/Makefile b/devel/shiboken2/Makefile
index 6cbf45266fbf..63de66c748b2 100644
--- a/devel/shiboken2/Makefile
+++ b/devel/shiboken2/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@$
LIB_DEPENDS= libclang.so.${LLVM_DEFAULT:C/^([6-9])0/\1/}:devel/llvm${LLVM_DEFAULT} \
libxslt.so:textproc/libxslt
-USES= cmake compiler:c++11-lang gnome python:3.5+ qt:5 shebangfix tar:xz
+USES= cmake compiler:c++11-lang gnome python:3.5-3.9 qt:5 shebangfix tar:xz
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_PYTHON= flavors
@@ -36,6 +36,10 @@ CMAKE_ARGS+= "-DCMAKE_CXX_FLAGS=-lexecinfo" \
.include <bsd.port.pre.mk>
+.if ${PYTHON_REL} < 30800
+BROKEN= does not build (plist issues)
+.endif
+
PLIST_SUB+= DISTVERSION=${DISTVERSION}
PLIST_SUB+= PYVERSTR=.cpython-${PYTHON_SUFFIX}${PYTHON_ABIVER}