aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-05-24 09:19:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-05-24 09:19:21 +0000
commitd7f10130e0f3e48c29d71f14d963076bdd5bf979 (patch)
tree7ab9106d2f80946a2c90bd30d665dc7f52f08293
parent5b8888a8765f40addc5cc6c4d29638f348e07d1b (diff)
downloadports-d7f10130e0f3e48c29d71f14d963076bdd5bf979.tar.gz
ports-d7f10130e0f3e48c29d71f14d963076bdd5bf979.zip
mail/mlmmj: add a patch to disable bounce probe
-rw-r--r--mail/mlmmj/Makefile2
-rw-r--r--mail/mlmmj/files/patch-nobounceprobe15
2 files changed, 16 insertions, 1 deletions
diff --git a/mail/mlmmj/Makefile b/mail/mlmmj/Makefile
index 68246d50377c..56d557d7f4b1 100644
--- a/mail/mlmmj/Makefile
+++ b/mail/mlmmj/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mlmmj
PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://mlmmj.org/releases/
diff --git a/mail/mlmmj/files/patch-nobounceprobe b/mail/mlmmj/files/patch-nobounceprobe
new file mode 100644
index 000000000000..d0548d25f8d9
--- /dev/null
+++ b/mail/mlmmj/files/patch-nobounceprobe
@@ -0,0 +1,15 @@
+diff --git src/mlmmj-maintd.c src/mlmmj-maintd.c
+index 02cfd16..5ac35da 100644
+--- src/mlmmj-maintd.c
++++ src/mlmmj-maintd.c
+@@ -601,6 +601,10 @@ int probe_bouncers(const char *listdir, const char *mlmmjbounce)
+ pid_t pid, childpid;
+ int status;
+
++ if (statctrl(listdir, "nobounceprobe")) {
++ return 0;
++ }
++
+ if(chdir(dirname) < 0) {
+ log_error(LOG_ARGS, "Could not chdir(%s)", dirname);
+ myfree(dirname);