aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-05-16 18:27:24 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-05-16 18:29:41 +0000
commitd8ab41d67f9f7e9a9bb1069f2a4d1ded1f2561e9 (patch)
treee99c641a6bb25b13c394c8d806d40c007b2b3c21
parent059d6f9f7619b94801b77d944e8777e6a38c194e (diff)
downloadports-d8ab41d67f9f7e9a9bb1069f2a4d1ded1f2561e9.tar.gz
ports-d8ab41d67f9f7e9a9bb1069f2a4d1ded1f2561e9.zip
sysutils/py-diffoscope: Update to 175
Patch removed was incorporated upstream. The project now supports only Python 3.7+. Approved by: koobs (maintainer, implicit)
-rw-r--r--sysutils/py-diffoscope/Makefile4
-rw-r--r--sysutils/py-diffoscope/distinfo6
-rw-r--r--sysutils/py-diffoscope/files/patch-diffoscope_main.py14
3 files changed, 5 insertions, 19 deletions
diff --git a/sysutils/py-diffoscope/Makefile b/sysutils/py-diffoscope/Makefile
index ef13af468e29..94f9ef7a1386 100644
--- a/sysutils/py-diffoscope/Makefile
+++ b/sysutils/py-diffoscope/Makefile
@@ -1,7 +1,7 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= diffoscope
-PORTVERSION= 147
+PORTVERSION= 175
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +20,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
isoinfo:sysutils/cdrkit \
rpm2cpio:archivers/rpm2cpio
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/sysutils/py-diffoscope/distinfo b/sysutils/py-diffoscope/distinfo
index fcbbedb9d63e..8d32aced8f6e 100644
--- a/sysutils/py-diffoscope/distinfo
+++ b/sysutils/py-diffoscope/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592225921
-SHA256 (diffoscope-147.tar.gz) = 5b5fdaa4d900c891b319e4b9a006eb16824a0b61fdbe15e75acbbe35602e2da6
-SIZE (diffoscope-147.tar.gz) = 1570418
+TIMESTAMP = 1621177362
+SHA256 (diffoscope-175.tar.gz) = b87481752815140e35088647ccdea13297e41a2d72772e842590360b662f7533
+SIZE (diffoscope-175.tar.gz) = 1590841
diff --git a/sysutils/py-diffoscope/files/patch-diffoscope_main.py b/sysutils/py-diffoscope/files/patch-diffoscope_main.py
deleted file mode 100644
index 246b2cac77b0..000000000000
--- a/sysutils/py-diffoscope/files/patch-diffoscope_main.py
+++ /dev/null
@@ -1,14 +0,0 @@
-# Add a patch from Mattia Rizzolo to prevent tests
-# from failing due to the no-tlsh-module warning.
-
---- diffoscope/main.py.orig 2020-06-11 11:45:39 UTC
-+++ diffoscope/main.py
-@@ -658,7 +658,7 @@ def run_diffoscope(parsed_args):
-
- ProfileManager().setup(parsed_args)
- PresenterManager().configure(parsed_args)
-- if not tlsh:
-+ if not tlsh and "PYTEST_CURRENT_TEST" not in os.environ:
- logger.warning(
- 'Fuzzy-matching is currently disabled as the "tlsh" module is unavailable.'
- )