aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-11 21:56:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-12 04:49:07 +0000
commitd8c0758d48b5e421f3f5cf9ffc7fa30171cbb149 (patch)
treeaaf40338fd1e28a63b31661fb253639363c0fbf1
parentfe0473dc1f1c703e8367efc5dc0104beb7da8815 (diff)
downloadports-d8c0758d48b5e421f3f5cf9ffc7fa30171cbb149.tar.gz
ports-d8c0758d48b5e421f3f5cf9ffc7fa30171cbb149.zip
misc/py-SQSnobFit: New port: Stable Noisy Optimization by Branch and FIT quantum computer algorithm
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-SQSnobFit/Makefile25
-rw-r--r--misc/py-SQSnobFit/distinfo3
-rw-r--r--misc/py-SQSnobFit/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b086f6252610..59d8b25c696d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -396,6 +396,7 @@
SUBDIR += py-QSpectrumAnalyzer
SUBDIR += py-SQCommon
SUBDIR += py-SQImFil
+ SUBDIR += py-SQSnobFit
SUBDIR += py-SimpleSoapy
SUBDIR += py-SoapySDR
SUBDIR += py-alive-progress
diff --git a/misc/py-SQSnobFit/Makefile b/misc/py-SQSnobFit/Makefile
new file mode 100644
index 000000000000..5b898d8de9ad
--- /dev/null
+++ b/misc/py-SQSnobFit/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= SQSnobFit
+DISTVERSION= 0.4.5
+CATEGORIES= misc math python # quantum-computing
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Stable Noisy Optimization by Branch and FIT quantum computer algorithm
+WWW= https://qat4chem.lbl.gov/software
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}SQCommon>0:misc/py-SQCommon@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-SQSnobFit/distinfo b/misc/py-SQSnobFit/distinfo
new file mode 100644
index 000000000000..477393c3031d
--- /dev/null
+++ b/misc/py-SQSnobFit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1699738258
+SHA256 (SQSnobFit-0.4.5.tar.gz) = de652aca1fa998dc2235b18d4caec5a225847d40b411f0351fab6f2d4877300f
+SIZE (SQSnobFit-0.4.5.tar.gz) = 29105
diff --git a/misc/py-SQSnobFit/pkg-descr b/misc/py-SQSnobFit/pkg-descr
new file mode 100644
index 000000000000..36638fd86d3a
--- /dev/null
+++ b/misc/py-SQSnobFit/pkg-descr
@@ -0,0 +1,4 @@
+SnobFit is intended for optimizing on derivative-free, noisy, blackbox
+functions. This modified version has preset defaults as intended for hybrid
+quantum-classical algorithms run on Noisy Intermediate Scale Quantum (NISQ)
+computers.