aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2022-06-21 17:29:04 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2022-06-21 17:37:28 +0000
commitd91a0855b7998f68c07134a387bad57ae7b513c1 (patch)
tree2195f53a3676f1d5dd02a9743830d605fcab5931
parent40568cac8e3e1931ca48becdfd18e2bf0aab1061 (diff)
downloadports-d91a0855b7998f68c07134a387bad57ae7b513c1.tar.gz
ports-d91a0855b7998f68c07134a387bad57ae7b513c1.zip
devel/p5-AnyEvent-Subprocess: add small fix
There is a bug in AnyEvent::Subprocess since 2015, which requires a one line patch and unfortunately the authors of AnyEvent::Subprocess still did not fix it. This bug produces a warning on resent versions of Moose during startup: Passing a list of values to enum is deprecated. Enum values should be wrapped in an arrayref. at /usr/local/lib/perl5/site_perl/AnyEvent/Subprocess/Types.pm line 42. See also: https://github.com/zhmylove/pwsvpn Reported by: Sergei Zhmylove
-rw-r--r--devel/p5-AnyEvent-Subprocess/Makefile2
-rw-r--r--devel/p5-AnyEvent-Subprocess/files/patch-lib_AnyEvent_Subprocess_Types.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/p5-AnyEvent-Subprocess/Makefile b/devel/p5-AnyEvent-Subprocess/Makefile
index 20acc8508e9c..07e659577c43 100644
--- a/devel/p5-AnyEvent-Subprocess/Makefile
+++ b/devel/p5-AnyEvent-Subprocess/Makefile
@@ -2,7 +2,7 @@
PORTNAME= AnyEvent-Subprocess
PORTVERSION= 1.102912
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/devel/p5-AnyEvent-Subprocess/files/patch-lib_AnyEvent_Subprocess_Types.pm b/devel/p5-AnyEvent-Subprocess/files/patch-lib_AnyEvent_Subprocess_Types.pm
new file mode 100644
index 000000000000..1dc8590a804b
--- /dev/null
+++ b/devel/p5-AnyEvent-Subprocess/files/patch-lib_AnyEvent_Subprocess_Types.pm
@@ -0,0 +1,11 @@
+--- lib/AnyEvent/Subprocess/Types.pm.orig 2011-02-25 19:36:55 UTC
++++ lib/AnyEvent/Subprocess/Types.pm
+@@ -39,7 +39,7 @@ coerce SubprocessCode, from ArrayRef[Str], via {
+ subtype CodeList, as ArrayRef[CodeRef];
+ coerce CodeList, from CodeRef, via { [$_] };
+
+-enum WhenToCallBack, qw/Readable Line/;
++enum WhenToCallBack, [qw/Readable Line/];
+
+ 1;
+