aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-10-13 12:53:09 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-10-13 12:53:53 +0000
commitd92344039b4350674d959be16d5a2cfe07f87172 (patch)
tree46e7c0aac20cd615909e608c7148a69e1db4d197
parent7a6696ab2619c2661b8af49f1ee6eb4d1d9caf46 (diff)
downloadports-d92344039b4350674d959be16d5a2cfe07f87172.tar.gz
ports-d92344039b4350674d959be16d5a2cfe07f87172.zip
biology/py-py2bit: Python interface for 2bit packed nucleotide files
py2bit is a python extension, written in C, for quick access to 2bit files for randomly accessible, packed nucleotide sequences. The extension uses lib2bit for file access.
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-py2bit/Makefile16
-rw-r--r--biology/py-py2bit/distinfo3
-rw-r--r--biology/py-py2bit/pkg-descr5
4 files changed, 25 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index c779368ef1d2..3f2fb1f06f13 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -159,6 +159,7 @@
SUBDIR += py-orange3-bioinformatics
SUBDIR += py-orange3-single-cell
SUBDIR += py-pandas-charm
+ SUBDIR += py-py2bit
SUBDIR += py-pyfaidx
SUBDIR += py-pysam
SUBDIR += py-python-libsbml
diff --git a/biology/py-py2bit/Makefile b/biology/py-py2bit/Makefile
new file mode 100644
index 000000000000..7295e91ed18f
--- /dev/null
+++ b/biology/py-py2bit/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= py2bit
+DISTVERSION= 0.3.0
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Python interface for 2bit packed nucleotide files
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/biology/py-py2bit/distinfo b/biology/py-py2bit/distinfo
new file mode 100644
index 000000000000..a797a50f82d2
--- /dev/null
+++ b/biology/py-py2bit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617287956
+SHA256 (py2bit-0.3.0.tar.gz) = 450555c40cba66957ac8c9a4b6afb625fb34c4bb41638de78c87661ff8b682ef
+SIZE (py2bit-0.3.0.tar.gz) = 16010
diff --git a/biology/py-py2bit/pkg-descr b/biology/py-py2bit/pkg-descr
new file mode 100644
index 000000000000..f6a726605c5e
--- /dev/null
+++ b/biology/py-py2bit/pkg-descr
@@ -0,0 +1,5 @@
+py2bit is a python extension, written in C, for quick access to 2bit
+files for randomly accessible, packed nucleotide sequences. The
+extension uses lib2bit for file access.
+
+WWW: https://github.com/deeptools/py2bit