aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-07-15 06:22:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-07-15 06:22:36 +0000
commitd94d5da10640ad4b8d871a9b3e99a70bbd60b0e1 (patch)
treeaa9a187af603bfc4c120dd74dae955da19f40df1
parentb396b2af371a5c318c6e3a6dec24d3401bc124c3 (diff)
downloadports-d94d5da10640ad4b8d871a9b3e99a70bbd60b0e1.tar.gz
ports-d94d5da10640ad4b8d871a9b3e99a70bbd60b0e1.zip
deskutils/semantik: update to 1.2.7
- While here, reorder Makefile to follow the convention.
-rw-r--r--deskutils/semantik/Makefile18
-rw-r--r--deskutils/semantik/distinfo6
-rw-r--r--deskutils/semantik/files/patch-wscript15
3 files changed, 20 insertions, 19 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index 9a9389a15357..d2bda63507af 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -1,5 +1,5 @@
PORTNAME= semantik
-DISTVERSION= 1.2.6
+DISTVERSION= 1.2.7
CATEGORIES= deskutils kde
MASTER_SITES= https://waf.io/
@@ -16,17 +16,11 @@ USES= kde:5 pkgconfig python:3.6+ qt:5 shebangfix tar:bzip2 waf \
desktop-file-utils gettext shared-mime-info
USE_KDE= auth config configwidgets coreaddons i18n iconthemes \
kdelibs4support kio sonnet widgetsaddons xmlgui
+USE_LDCONFIG= yes
USE_QT= core dbus declarative gui location network printsupport \
svg webchannel webengine widgets xml \
buildtools_build qmake_build
-CONFIGURE_ENV= PATH="${KDE_PREFIX}/bin:$$PATH" \
- WAF_HOME="${WRKSRC}"
-CPPFLAGS+= -I${LOCALBASE}/include
-CFLAGS+= -I${LOCALBASE}/include
-MAKE_ENV= DESTDIR="${STAGEDIR}"
-USE_LDCONFIG= yes
-
SHEBANG_FILES= src/templates/beamer/wscript \
src/templates/pdflatex/wscript \
src/filters/fvym.py \
@@ -38,6 +32,12 @@ SHEBANG_FILES= src/templates/beamer/wscript \
waf \
wscript
+CONFIGURE_ENV= PATH="${KDE_PREFIX}/bin:$$PATH" \
+ WAF_HOME="${WRKSRC}"
+MAKE_ENV= DESTDIR="${STAGEDIR}"
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+
PLIST_SUB= PORTVERSION="${PORTVERSION}"
OPTIONS_DEFINE= NLS
@@ -57,7 +57,7 @@ post-configure:
# poudriere build don't necessarily reach /usr/local/include either.
@${REINPLACE_CMD} -e "s+..PWD............/include+${LOCALBASE}/include+g" \
${WRKSRC}/build/c4che/_cache.py
-
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-d \
diff --git a/deskutils/semantik/distinfo b/deskutils/semantik/distinfo
index c020780ff450..0bdadd14fc01 100644
--- a/deskutils/semantik/distinfo
+++ b/deskutils/semantik/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616097322
-SHA256 (semantik-1.2.6.tar.bz2) = 3b33b4b4ab92158598d05b0d38cba2bca2b062927989249466bca668cfb7a635
-SIZE (semantik-1.2.6.tar.bz2) = 627853
+TIMESTAMP = 1626329172
+SHA256 (semantik-1.2.7.tar.bz2) = 6544bb9aef29a680570eae864986ef56fd45b75778f38c85efd99f20b82f069d
+SIZE (semantik-1.2.7.tar.bz2) = 628473
diff --git a/deskutils/semantik/files/patch-wscript b/deskutils/semantik/files/patch-wscript
index e2dd370943fb..8e1c619fdb23 100644
--- a/deskutils/semantik/files/patch-wscript
+++ b/deskutils/semantik/files/patch-wscript
@@ -1,12 +1,13 @@
---- wscript.orig 2021-03-18 23:07:57 UTC
+--- wscript.orig 2021-07-15 06:06:13 UTC
+++ wscript
-@@ -220,20 +220,9 @@ def configure(conf):
+@@ -220,21 +220,11 @@ def configure(conf):
conf.env.append_value('LIB_KDECORE', 'KF5KDELibs4Support')
-- for x in ('', '/usr/include/KF5/KDELibs4Support', '/usr/local/include/KF5/KDELibs4Support'):
-- conf.env.stash()
-+ for x in ('@@LOCALBASE@@/include/KF5/KDELibs4Support', "bogus"):
+- kdelibs4support_candidates = ['', '/usr/include/KF5/KDELibs4Support', '/usr/local/include/KF5/KDELibs4Support']
++ kdelibs4support_candidates = ['@@LOCALBASE@@/include/KF5/KDELibs4Support', "bogus"]
+ for x in kdelibs4support_candidates:
+ conf.env.stash()
if os.path.exists(x):
conf.env.append_value('INCLUDES_KDECORE', x)
- try:
@@ -17,8 +18,8 @@
- break
- except conf.errors.ConfigurationError:
- conf.env.revert()
-- else:
-- conf.fatal('kdelibs4support was not found, check the config.log file')
+- else:
+- conf.fatal('kdelibs4support was not found, check the config.log file')
for x in ('', '/usr/local/include'):
conf.env.stash()